Bug 38790 - Crashes during install
Crashes during install
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.1
alpha Linux
medium Severity medium
: ---
: ---
Assigned To: Phil Copeland
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-05-02 13:51 EDT by Chris Adams
Modified: 2007-04-18 12:32 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-06-25 09:34:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Adams 2001-05-02 13:51:34 EDT
I have attempted to install wolverine on an AlphaServer 1000A/300 here
twice (once in X and once in text).  The X install froze part of the way
through with no message, while the text install gave me:

Kernel panic: Aiee, killing interrupt handler!
In interrupt handler - not syncing

It crashed while I wasn't looking (of course), but the CD was ejected on
the text install, so it may have been about to request disc 2 when it
crashed.  I was doing a fairly minimal Custom install with only Development
and Kernel Development package groups selected.

I don't think it is anything hardware related; I installed 7.0 on this
system okay and just recently installed Digital Unix 4.0F on it as well
(this is my test machine).
Comment 1 Phil Copeland 2001-05-02 15:44:12 EDT
Brock, do we have an AlphaServer 1000A/300 here?
I found one Alphaserver 1000 4/266 but it's not the same model,.. heck I'll use
that instead it's roughly the same.
Thus Far it seems to be installing fine... in fact it has installed fine after
45 mionutes.

Can you give me some extra info like what boot kernel it's using, what the HW
config is etc?

Phil
=--=
Comment 2 Chris Adams 2001-05-02 16:12:19 EDT
I used /kernels/vmlinux.gz (the only kernel I see on the CD).  The
system has 512MB RAM, a pair of 2G hard drives (RZ29B), and the standard
CD-ROM (RRD45) and tape drive (TLZ07).  The only card plugged in is the
ethernet card (standard DEC Tulip 21140 card).

I did a text install with no package groups selected, and it went okay.
The problem appears to be something with changing the CD maybe?  The
crash in the text install was with "ncompress" displayed as the package
about to be installed, which is on disc 2 (disc 1 was ejected but the
prompt for disc 2 was not shown).

I'll do some more tests with the other drive (for the install that
worked I only installed to the first drive).  I'll stay in text mode so
I can see any errors, but when it crashed, it completely froze up, so I
don't know that that will help.
Comment 3 Chris Adams 2001-05-02 16:57:00 EDT
Okay, I just did another install (that took two discs) and it worked
okay.  The others were all "Custom" installs, for this one I did a
"Server" install and selected "DNS server".  It got to ncompress, asked
for the second disc, I loaded it, and it went on and finished.

I don't know what happened the first two times; I try some more things
and let you know if it happens again.
Comment 4 Chris Adams 2001-05-08 18:00:13 EDT
I'm reopening this bug.

Have you tried an install with software RAID partitions?  I am getting
this when I do the following:

1) Boot the system and boot the CD with "boot -fl 0 dka400"
2) The X installer loads and I go through mostly default selections (I
   chose "Server" for the install type).
3) I have two disks.  I partition them identically (using fdisk) and
   then set up software RAID (I make the partitions type "fd").
4) I chose only "DNS Server" at the package selection screen (I didn't
   choose "select individual packages").
5) The installer created the RAID partitions and filesystems, but when
   it tried to format the swap space, it crashed with the same kernel
   panic.

I did this several times with a couple of variations (did a "Custom"
install and selected individual packages, but still with software RAID)
and got the same kernel panic.

Has anyone tested software RAID on Alpha with this kernel?
Comment 5 Phil Copeland 2001-06-04 15:56:16 EDT
Yes I've tested sw raid0 on a UP2000

/dev/sda1                54441     36726     14904  72% /boot
/dev/md0             103636992   5518220  92854248   6% /compile
/dev/hde6              3096240    638000   2300892  22% /home

/dev/sda:
 Timing buffered disk reads:  64 MB in  9.59 seconds =  6.67 MB/sec

/dev/hde:
 Timing buffered disk reads:  64 MB in  2.56 seconds = 24.97 MB/sec

/dev/md0:
 Timing buffered disk reads:  64 MB in  1.30 seconds = 49.37 MB/sec

and I've been banging on this machine for oh,.. a month or so now
Linux dhcpd156.meridian.redhat.com 2.4.3-10smp #1 SMP Thu May 31 23:19:52 EDT
2001 alpha unknown
Comment 6 Chris Adams 2001-06-04 16:20:23 EDT
Well, all my problems are with RAID1.  I sent some oopses to bug #40586,
which has been marked as a duplicate of #38791, but they are really two
different things.  #40586 is that software RAID1 crashes, while #38791
is that software RAID (any level) doesn't autorun from the kernel on
non-MSDOS partitions.

I hate to keep beating a dead horse, because if nobody else is seeing
this then I guess I've just got something weird going on.  I'm 99.999%
sure it isn't hardware though; I had no hardware trouble with Red Hat
7.0, Digital Unix 4.0G, or Tru64 5.1 on this box.

I have no trouble reproducing it under 7.1 RC1; I just boot up and try
to ssh in (my home directory is on the RAID1 filesystem of /usr/local).
I cannot log in and I get a kernel oops from sshd.  I am running a
kernel with my patch (from #38791) and the RAID levels compiled in to
the kernel instead of modules (I was working to having the root
filesystem RAID as well).  I get the same results out of the stock Red
Hat kernel though (where RAID is started by the init scripts).
Comment 7 Phil Copeland 2001-06-24 15:35:11 EDT
Have you had the opepertunity to try this out on teh gold CD's? ie real 7.1 yet?

Phil
=--=
Comment 8 Chris Adams 2001-06-25 09:34:19 EDT
Yes, I tried the seawolf CDs when the hit the beta site.  I still get
the same thing - oops in raid1_read_balance.
Comment 9 Phil Copeland 2002-08-12 14:18:16 EDT
Welcome to RH 7.2...

Phil
=--=

Note You need to log in before you can comment on or make changes to this bug.