Bug 387921 - Cant get Novatel U727 usb EVDO modem to work on F8 when it works on knoppix and apparently FC6 as well
Cant get Novatel U727 usb EVDO modem to work on F8 when it works on knoppix a...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
8
All Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-16 18:58 EST by Kronos003
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-21 13:46:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Sprint_Mobile_Broadband_Setup_Guide for linux (2.31 MB, application/pdf)
2007-11-16 18:58 EST, Kronos003
no flags Details
setup script i use to start the card on a session by session basis (3.51 KB, application/x-shellscript)
2007-11-21 02:45 EST, Kronos003
no flags Details

  None (edit)
Description Kronos003 2007-11-16 18:58:53 EST
Description of problem:
I have a Novatel Wireless Ovation U727 USB EVDO Modem (sprint)
It seems that the usbserial kernel module behaves differently in F8 from
knoppix. this guide works in knoppix 5.1.1 but not in F 8 - it was written for
Fc6
http://www4.sprint.com/pcsbusiness/downloads/Sprint_Mobile_Broadband_Setup_Guide.pdf

Version-Release number of selected component (if applicable):
kernel-xen-2.6.21-2950.fc8
kernel-2.6.23.1-49.fc8

How reproducible:
without fail

Steps to Reproduce:
1. plugin U727
2. rmmod usbserial (or modprobe -r usbserial)
3. modprobe usbserial vendor=0x1410 device=0x4100
4. eject /dev/cdrom1
  
Actual results:

Internal mass storage device disenguages. microXD card reader enguages.
no serial ports

Expected results:

Internal mass storage device disenguages. 4 serial ports show up /dev/ttyUSB0,
/dev/ttyUSB1, /dev/ttyUSB2, /dev/ttyUSB3. and im told microXD card reader should
show as well. from there the rest of the guide would work.

Additional info:

In an attempt to make this thing work, ive added "options usbserial
vendor=0x1410 device=0x4100" to /etc/modprobe.conf. Ive also blacklisted
modules: cdrom, sr-mod, and usb-storage. no dice
Comment 1 Kronos003 2007-11-16 18:58:53 EST
Created attachment 262021 [details]
Sprint_Mobile_Broadband_Setup_Guide for linux
Comment 2 Kronos003 2007-11-16 19:07:47 EST
(In reply to comment #0)
This may not be local to fedora - looks like another user is having similar
issues in ubuntoo

http://www.evdoforums.com/thread7379.html
Comment 3 Chuck Ebbert 2007-11-19 18:11:32 EST
Do any messages show up in the system log after loading the usbserial module?
Comment 4 Kronos003 2007-11-20 20:35:04 EST
Here is the conversation with the machine while monitoring /var/log/messages
Key = A: Physical Action C#: command issued as root (su -) RL: Results in log
RC: Results in console

Running kernel:  2.6.21-2950.fc8xen #1 SMP Tue Oct 23 12:23:33 EDT 2007 x86_64
x86_64 x86_64 GNU/Linux

====== Start ======
A: Plugin U727
RL:
Nov 20 20:27:24 twing kernel: usb 3-1: new full speed USB device using ohci_hcd
and address 7
Nov 20 20:27:24 twing kernel: usb 3-1: configuration #1 chosen from 1 choice
Nov 20 20:27:24 twing kernel: scsi9 : SCSI emulation for USB Mass Storage devices
Nov 20 20:27:29 twing kernel: scsi 9:0:0:0: CD-ROM            Novatel  Mass
Storage     1.00 PQ: 0 ANSI: 2
Nov 20 20:27:29 twing kernel: sr1: scsi-1 drive
Nov 20 20:27:29 twing kernel: sr 9:0:0:0: Attached scsi generic sg2 type 5
Nov 20 20:27:29 twing kernel: sr1: CDROM (ioctl) error, command: Get
configuration 46 00 00 00 00 00 00 00 20 00
Nov 20 20:27:29 twing kernel: sr: Sense Key : No Sense [current] 
Nov 20 20:27:29 twing kernel: sr: Add. Sense: No additional sense information
Nov 20 20:27:30 twing kernel: sr1: CDROM (ioctl) error, command: Get
configuration 46 00 00 00 00 00 00 00 20 00
Nov 20 20:27:30 twing kernel: sr: Sense Key : No Sense [current] 
Nov 20 20:27:30 twing kernel: sr: Add. Sense: No additional sense information
Nov 20 20:27:30 twing kernel: sr1: CDROM (ioctl) error, command: Get
configuration 46 00 00 28 00 00 00 00 10 00
Nov 20 20:27:30 twing kernel: sr: Sense Key : No Sense [current] 
Nov 20 20:27:30 twing kernel: sr: Add. Sense: No additional sense information
Nov 20 20:27:30 twing kernel: sr1: CDROM (ioctl) error, command: Get
configuration 46 00 00 20 00 00 00 00 18 00
Nov 20 20:27:30 twing kernel: sr: Sense Key : No Sense [current] 
Nov 20 20:27:30 twing kernel: sr: Add. Sense: No additional sense information
Nov 20 20:27:30 twing kernel: sr1: CDROM (ioctl) error, command: Get
configuration 46 00 00 00 00 00 00 00 20 00
Nov 20 20:27:30 twing kernel: sr: Sense Key : No Sense [current] 
Nov 20 20:27:30 twing kernel: sr: Add. Sense: No additional sense information
Nov 20 20:27:30 twing kernel: UDF-fs: Partition marked readonly; forcing
readonly mount
Nov 20 20:27:30 twing kernel: UDF-fs INFO UDF 0.9.8.1 (2004/29/09) Mounting
volume 'SMB Lite v3.10.011', timestamp 2007/08/24 20:22 (1ed4)
Nov 20 20:27:30 twing hald: mounted /dev/sr1 on behalf of uid 500

C#:rmmod usbserial
RC#:ERROR: Module usbserial does not exist in /proc/modules

C#:modprobe usbserial vendor=0x1410 device=0x4100
RC:FATAL: Error inserting usbserial
(/lib/modules/2.6.21-2950.fc8xen/kernel/drivers/usb/serial/usbserial.ko):
Unknown symbol in module, or unknown parameter (see dmesg)
RL:Nov 20 20:24:43 twing kernel: usbserial: Unknown parameter `device'
ME:Oops that vendor should be product

C#:modprobe usbserial vendor=0x1410 product=0x4100
RL:Nov 20 20:28:14 twing kernel: usbcore: registered new interface driver usbserial
Nov 20 20:28:14 twing kernel: drivers/usb/serial/usb-serial.c: USB Serial
support registered for generic
Nov 20 20:28:14 twing kernel: usbcore: registered new interface driver
usbserial_generic
Nov 20 20:28:14 twing kernel: drivers/usb/serial/usb-serial.c: USB Serial Driver
core

C#:eject /dev/cdrom1
RL:Nov 20 20:29:29 twing kernel: usb 3-1: USB disconnect, address 7
Nov 20 20:29:30 twing kernel: usb 3-1: new full speed USB device using ohci_hcd
and address 8
Nov 20 20:29:30 twing kernel: usb 3-1: configuration #1 chosen from 1 choice
Nov 20 20:29:30 twing kernel: usbserial_generic 3-1:1.0: generic converter detected
Nov 20 20:29:30 twing kernel: usb 3-1: generic converter now attached to ttyUSB0
Nov 20 20:29:30 twing kernel: usbserial_generic 3-1:1.1: generic converter detected
Nov 20 20:29:30 twing kernel: usb 3-1: generic converter now attached to ttyUSB1
Nov 20 20:29:30 twing kernel: usbserial_generic 3-1:1.2: generic converter detected
Nov 20 20:29:30 twing kernel: usb 3-1: generic converter now attached to ttyUSB2
Nov 20 20:29:30 twing kernel: usbserial_generic 3-1:1.3: generic converter detected
Nov 20 20:29:30 twing kernel: usb 3-1: generic converter now attached to ttyUSB3
Nov 20 20:29:30 twing kernel: scsi10 : SCSI emulation for USB Mass Storage devices
Nov 20 20:29:35 twing kernel: scsi 10:0:0:0: Direct-Access     Novatel  MMC
Storage      2.31 PQ: 0 ANSI: 2
Nov 20 20:29:35 twing kernel: sd 10:0:0:0: [sdb] Attached SCSI removable disk
Nov 20 20:29:35 twing kernel: sd 10:0:0:0: Attached scsi generic sg2 type 0
ME: Hey! what the? it looks like im getting the serial ports i need...hmm time
to check this out... - ill come back and report if it doesnt work. expect
another report in 24hrs. We MIGHT have found the issue - USer error - maybe -
will run test to completion and report back with results. will run test twice
for start to connect and download on each kernel xen and non xen.
Comment 5 Kronos003 2007-11-21 02:45:33 EST
Created attachment 265741 [details]
setup script i use to start the card on a session by session basis

hopefully this script saves some headache
Comment 6 Kronos003 2007-11-21 02:47:19 EST
ok report is in. I dont think i should qualify this as a kernel bug since in all
fairness on my fedora box i was copying and pasting from a site. this is what i
was noticing while i was making my setup script. i was wondering WHY i could
type it in on the cli and it would work but the script would fail to produce
serial ports.
--- Excerpt from my attached script which anyone is free to use ---
#Wrong way - notice those wierd not quite x's
#modprobe usbserial vendor=0×1410 product=0×5010 # U727 Normal Mode um no serial
ports here
#
#right way
#modprobe usbserial vendor=0x1410 product=0x5010 # U727 Normal Mode um no serial
ports here
#modprobe usbserial vendor=0x1410 product=04100 # U727 NDIS MODE

I tested on both sides of my fedora 8 box and everything works as expected. i
made an automated script which hopefully will make life easier for others with
this card.

Note You need to log in before you can comment on or make changes to this bug.