Bug 3880 - ls -l of samba mounted disks prints wrong date
ls -l of samba mounted disks prints wrong date
Status: CLOSED DUPLICATE of bug 3447
Product: Red Hat Linux
Classification: Retired
Component: samba (Show other bugs)
6.0
i386 Linux
low Severity low
: ---
: ---
Assigned To: Trond Eivind Glomsrxd
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-07-03 04:43 EDT by Kern Sibbald
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-07-06 10:57:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kern Sibbald 1999-07-03 04:43:28 EDT
I am running Samba 2.0.3-8 as distributed on the RedHat 6.0
release.

First problem: apparently someone changed the syntax of
smbmount. Well, that broke a number of scripts. I fixed
them, so it is no major problem.

Second problem: when I mount my NT Server/Workstation disk,
all seems to be OK, but an ls -l listing produces dates
that are incorrect.
I am running NT 4.0 Service Pack 5.  An example of an
incorrect ls listing follows. Note, the dates should
correspond to the dates in the filename. Not more than 10
minutes ago, I wrote the file pmatouPartion03Jul1999, yet
in the ls listing, it has the date Aug 5 1998. It even
thinks that we have dates in 2021 !

The NT disk is mounted on the Linux machine with the
following commands:

USER=xxx%yyyy
smbmount \\\\minou\\ntd$ -c 'mount /mnt/ntd$'

Note, if I connect interactively with smbclient; cd to the
LinuxBackup directory and then do a dir, I get a listing
with the correct dates.

Best regards,

Kern Sibbald

ls l /mnt/ntd$/LinuxBackup
-rwxrwxr-x   1 root     root        13050 Jul 22  1983
deuterPartial25Jun1999.gz.25
-rwxrwxr-x   1 root     root     209565657 Jun 24  1944
matou01Jun1999.22.gz
-rwxrwxr-x   1 root     root     213245140 Mar 11  1968
matou06Jun1999.22.gz
-rwxrwxr-x   1 root     root     211174367 May 15  1994
matou13Jun1999.23.gz
-rwxrwxr-x   1 root     root     211190089 Dec 17  2018
matou20Jun1999.24.gz
-rwxrwxr-x   1 root     root     137461100 Dec  3  1997
matou27Jun1999.25.gz
-rwxrwxr-x   1 root     root        13536 Apr 14  1969
matouPartial01Jul1999.gz.26
-rwxrwxr-x   1 root     root        26459 Jun 27  1998
matouPartial02Jul1999.gz.26
-rwxrwxr-x   1 root     root        12599 Nov 17  1995
matouPartial02Jun1999.gz.22
-rwxrwxr-x   1 root     root        26690 Jan 13  2021
matouPartial03Jul1999.gz.26
-rwxrwxr-x   1 root     root        12580 May  4  1902
matouPartial04Jun1999.gz.22
-rwxrwxr-x   1 root     root        12581 Feb  8  1927
matouPartial05Jun1999.gz.22
-rwxrwxr-x   1 root     root        14106 Jan 21  1975
matouPartial07Jun1999.gz.23
-rwxrwxr-x   1 root     root        14114 Aug 26  1996
matouPartial08Jun1999.gz.23
-rwxrwxr-x   1 root     root        14293 Jul 27  2018
matouPartial09Jun1999.gz.23
-rwxrwxr-x   1 root     root        14219 Jun  7  1903
matouPartial10Jun1999.gz.23
-rwxrwxr-x   1 root     root        14514 Nov 19  1927
matouPartial11Jun1999.gz.23
-rwxrwxr-x   1 root     root        14531 Sep 30  1950
matouPartial12Jun1999.gz.23
-rwxrwxr-x   1 root     root        13353 Aug 17  1993
matouPartial14Jun1999.gz.24
-rwxrwxr-x   1 root     root        13355 Nov 10  2015
matouPartial15Jun1999.gz.24
-rwxrwxr-x   1 root     root        13356 Apr 22  1902
matouPartial16Jun1999.gz.24
-rwxrwxr-x   1 root     root        13355 Mar  4  1925
matouPartial17Jun1999.gz.24
-rwxrwxr-x   1 root     root        13355 May 28  1947
matouPartial18Jun1999.gz.24
-rwxrwxr-x   1 root     root        13355 Apr  8  1970
matouPartial19Jun1999.gz.24
-rwxrwxr-x   1 root     root        13398 Sep 25  2014
matouPartial21Jun1999.gz.25
-rwxrwxr-x   1 root     root        13404 Oct  7  1902
matouPartial22Jun1999.gz.25
-rwxrwxr-x   1 root     root        13405 Sep  5  1924
matouPartial23Jun1999.gz.25
-rwxrwxr-x   1 root     root        13405 Jul 19  1947
matouPartial24Jun1999.gz.25
-rwxrwxr-x   1 root     root        13434 Dec 16  1992
matouPartial26Jun1999.gz.25
-rwxrwxr-x   1 root     root        13535 Apr 10  1902
matouPartial28Jun1999.gz.26
-rwxrwxr-x   1 root     root        13535 Feb 20  1925
matouPartial29Jun1999.gz.26
-rwxrwxr-x   1 root     root        13536 Apr  9  1949
matouPartial30Jun1999.gz.26
-rwxrwxr-x   1 root     root     83416829 Feb  3  1957
pmatou01Jul1999.26.gz
-rwxrwxr-x   1 root     root        16053 Aug  5  1998
pmatouPartial03Jul1999.gz.26
Comment 1 Bill Nottingham 1999-07-06 10:57:59 EDT
*** This bug has been marked as a duplicate of 3447 ***

Note You need to log in before you can comment on or make changes to this bug.