Bug 38813 - pages load slowly when using lvs
pages load slowly when using lvs
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: piranha (Show other bugs)
6.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Phil Copeland
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-05-02 15:44 EDT by Bowie Bailey
Modified: 2007-04-18 12:32 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-02 17:26:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
lvs.cf (653 bytes, text/plain)
2001-05-02 15:45 EDT, Bowie Bailey
no flags Details

  None (edit)
Description Red Hat Bugzilla 2001-05-02 15:44:17 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows 98)


I have an LVS-DR pool.  When I hit the realservers directly, they respond 
almost instantly.  When I hit the VIP, the wepages come up very slowly.  
In particular, it seems to take a long time for it to recognize that an 
image is broken.

Reproducible: Always
Steps to Reproduce:
1.Configure basic LVS-DR with a realserver
2.Install WebBench content on the realserver
3.Go to the virtual URL and look at http://VIP/wbtree/6040_1.htm
(this is a page that has some text and three broken images)

	

Actual Results:  The page takes 45 seconds to 1 minute to complete loading.

Expected Results:  The page should load instantly.

The LVS server is running piranha-0.4.17-7 and kernel 2.2.16-4.

This problem was originally seen with NT realservers and then duplicated 
with a Linux realserver.  I have spoken with RedHat technical support.  
They were unable to help me and suggested that I submit the bug here.

I will attach the lvs.cf.
Comment 1 Red Hat Bugzilla 2001-05-02 15:45:20 EDT
Created attachment 17086 [details]
lvs.cf
Comment 2 Red Hat Bugzilla 2001-05-02 17:26:39 EDT
Upon further testing, the problem appears to be that requests for non-existent 
files are returning an "unable to reach server" error rather than a 404.  This 
happens on two of my servers one Linux server and one NT server.  The other NT 
server gives 404 errors as expected.

This problem only occurs when using the LVS.  If I connect to the realservers 
directly, they work as expected.
Comment 3 Red Hat Bugzilla 2001-05-07 16:46:37 EDT
I have talked directly with the Red Hat support people you've talked with. This
situation is very strange and no one has ever reported it before. This is
extremely unlikely that this is a piranha problem, as you are pretty much only
dealing the lvs, so I wouldn't even bother to start piranha while diagnosing
this (just do the ipvsadm and ifconfig setup yourself). If you can reproduce
this at will with just 1 Linux router and 1 Linux real server, I'd work with
that.

Although it is not obvious, I can't see how this could be anything except some
sort of ipchains, routing, or ipvs configuration problem. One thing you should
do is report this in the LVS discussion list so that you get a wider audience of
users (including WinNT), plus the LVS author Wensong, an opportunity to help.
You might also want to visit http://www.linuxvirtualserver.org/ and see if there
already exists some documentation that can help you (like the FAQ).

We are not able to reproduce the problem here unfortunately.
Comment 4 Red Hat Bugzilla 2001-05-07 16:54:25 EDT
oops.  I should have closed this problem myself earlier.  It turns out that my 
troubleshooting was not quite up to par that day.  The problem was that after 
we rebooted one of the realservers, it automatically re-added a route that 
screwed up the LVS. I was getting a 404 on the working server and nothing at 
all from the other one.  Apparently, I never tested a good page or image on 
that server through the LVS.

Note You need to log in before you can comment on or make changes to this bug.