Bug 38850 - lpd does not recognize port option as documented
Summary: lpd does not recognize port option as documented
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: lpr   
(Show other bugs)
Version: 6.2
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-05-02 21:35 UTC by Scott Gifford
Modified: 2007-04-18 16:32 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-12-18 22:43:11 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Fix for port# problem in lpr/lpd (2.25 KB, patch)
2001-05-02 21:39 UTC, Scott Gifford
no flags Details | Diff

Description Scott Gifford 2001-05-02 21:35:57 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.2.14-5.0 i686; en-US; 0.8.1)
Gecko/20010421


According to the lpd manpage, lpd accepts an optional 'port' parameter,
which tells it to listen for TCP connections on a port other than the one
specified in /etc/services.  This option does not work, and there is no
code in lpd.c to handle this case.

Bug 10133 is this same bug for RedHat 6.1, and it was closed with the
comment "Fixed in lpr-ng".  Well, I just installed RedHat 6.2, which still
ships with standard lpd, and installs it by default.  Please don't close
this out because it's fixed in lpr-ng until you RedHat has stopped shipping
standard lpr with any version of RedHat Linux; otherwise it's just a
cop-out.  :-)

I'll attach a patch against lpr 0.50 which fixes this problem

Reproducible: Always
Steps to Reproduce:
1.Run /usr/sbin/lpd 10515
2.Telnet to port 10515 to see your lpd listening

	

Actual Results:  It's not there!

Expected Results:  A connection to lpd.

Comment 1 Scott Gifford 2001-05-02 21:39:12 UTC
Created attachment 17126 [details]
Fix for port# problem in lpr/lpd

Comment 2 Scott Gifford 2001-05-02 21:40:17 UTC
This patch adds the bonus functionality of a specified port of 0 will stop lpd
from listening on a TCP socket at all.


Comment 3 Tim Waugh 2002-01-10 11:25:58 UTC
We use LPRng in the current release. (But thanks for the patch.)



Note You need to log in before you can comment on or make changes to this bug.