Bug 388721 - /usr/include/linux/cdrom.h should include limits.h
/usr/include/linux/cdrom.h should include limits.h
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-17 14:51 EST by David Juran
Modified: 2008-02-14 18:25 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-14 18:25:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Juran 2007-11-17 14:51:18 EST
Description of problem:
/usr/include/linux/cdrom.h is referring to INT_MAX but does not do an include in
 limit.h where it is defined. So any program that does an include on
linux/cdrom.h will fail compiling

Version-Release number of selected component (if applicable):
kernel-headers-2.6.23.1-49.fc8

How reproducible:
Every time
Comment 1 Chuck Ebbert 2007-11-19 16:33:28 EST
That fix was rejected on linux-kernel.
Comment 2 Christopher Brown 2008-02-13 17:40:14 EST
Hi David,

I'm reviewing this bug as part of the kernel bug triage project, an attempt to
isolate current bugs in the Fedora kernel.

http://fedoraproject.org/wiki/KernelBugTriage

Do you want this one leaving open or is it dead? Looks like dvd+rw-tools has
been patched with the include if that is the app you were concerned about...
Comment 3 David Juran 2008-02-14 13:35:54 EST
IMHO a header file should include all other header files from which it uses
symbols but if Chuck says that the upstream disagrees with me I guess there's
not much to do...
Comment 4 Christopher Brown 2008-02-14 18:25:39 EST
Yeah, here's the discussion if you're interested...

http://lkml.org/lkml/2007/11/10/54

Closing NOTABUG but feel free to re-open if this situation changes.

Note You need to log in before you can comment on or make changes to this bug.