Bug 388811 - dangling symlink
dangling symlink
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: kdebluetooth (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Gilboa Davara
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-17 15:56 EST by Denise Dumas
Modified: 2008-05-08 04:03 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-08 04:03:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Florian La Roche 2007-11-17 15:56:27 EST
Description of problem:

kdebluetooth has dangling symlink from
/usr/share/doc/HTML/ca/kdebluetooth/common to /usr/share/doc/HTML/ca/common

regards,

Florian La Roche



Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Gilboa Davara 2007-11-27 12:41:28 EST
Nice catch.
Will be fixed in the next release.
Comment 3 Steven M. Parrish 2008-05-07 18:37:15 EDT
Is this fixed?  Can it be closed?
Comment 4 Gilboa Davara 2008-05-07 19:25:03 EDT
Uggh. Nope, sorry. :(
The fix must have slipped through the cracks.
I'll reapply the fix tomorrow and release an update.

- Gilboa
Comment 5 Gilboa Davara 2008-05-08 04:03:51 EDT
OK. Now I remember:

The dangling symlink is part of the Catalan translation; If kde-i18n-Catalan is
installed, the symlink will dangle no more.
If I remove it, I'll lose the Catalan translation. (Far worse, depending on your
 KDE configuration, additional dangling symlinks may appear.)
Creating empty directories that aren't being owned by anyone is also a bad
solution. (Directories will not be removed if/when KDE is uninstalled)

P.S. The problem seems to be shared by a number of other KDE applications:
E.g. /usr/share/doc/HTML/fr/common which is pointed by
/usr/share/doc/HTML/fr/kdebluetooth/common is actually being owned by k3b. (A
bug by itself)

In short, IMHO the least offending solution is keeping the dangling symlink as
it is.

Changing to CANTFIX. 

- Gilboa

Note You need to log in before you can comment on or make changes to this bug.