Bug 38886 - mbox driver of imap is broken
mbox driver of imap is broken
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: imap (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-05-03 03:44 EDT by Dmitri A. Sergatskov
Modified: 2007-04-18 12:33 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-04 15:41:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dmitri A. Sergatskov 2001-05-03 03:44:31 EDT
Description of Problem:

The mbox driver of imap is broken -- it does not move read mail into
~/mbox, nor it reads ~/mbox at all.

How Reproducible:
100%

Steps to Reproduce:
1.send e-mail (to $USER), see it in /vars/spool/mail/$USER 
2. as $USER, read it through imap


Actual Results:

mail still in /var/spool/mail/$USER

Expected Results:

mail moved to ~/mbox

Additional Information:

Imap compiled from scratch works as expected.
Comment 1 Stephen Walton 2001-05-04 15:41:11 EDT
This seems to have been a deliberate decision.  If you install (with 'rpm 
--install') the imap source RPM and look in /usr/src/redhat/SOURCES, you'll 
see a file imap-2000-redhat.patch which deliberately patches away the mbox 
handling.  I built a new version with this patch removed and it works fine.

Comment 2 Mike A. Harris 2001-05-07 06:48:08 EDT
The disabling of the mbox driver was intentional, and is not a bug. I've
got my own reasons for not wanting to re-enable the mbox driver, although
I don't know why Nalin disabled it initially as that predates my employment.

I've Cc'd Nalin so he can comment, but I'm closing the bug report as I don't
consider it a bug.
Comment 3 Stephen Walton 2001-05-11 14:53:55 EDT
OK, it isn't a bug, but I'd like to gently suggest it may have been a bad
decision.  If no mode 0600 file named 'mbox' exists in a user's home directory,
imapd doesn't use the mbox driver, so no real harm is done if it is enabled by
default.  In addition, disabling it by default requires those of us who use the
functionality to rebuild imapd from source;  the behavior can't be changed by
simply editing a config file somewhere.

Note You need to log in before you can comment on or make changes to this bug.