Bug 38892 - RHN service level screen doesn't work with konqueror
RHN service level screen doesn't work with konqueror
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: kdelibs (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-05-03 05:07 EDT by Tim Waugh
Modified: 2007-04-18 12:33 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-03 05:49:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tim Waugh 2001-05-03 05:07:15 EDT
Description of Problem:
The Red Hat Network 'Assign Service Levels' screen doesn't work with 
konqueror; the buttons have no effect.

How Reproducible:
100%

Steps to Reproduce:
1. Register a newly-installed Seawolf machine with RHN
2. With Konqueror, go to www.redhat.com/network and logon
3. Click on 'Your network', and click on 'upgrade service'
4. Try to upgrade that machine to software manager service level

Actual Results:
The system name stays in the 'unassigned' box on the left hand side even 
when highlighting it and clicking 'upgrade'.  The 'update account' button 
also has no effect.

Expected Results:
'Update' should move the system to the right-hand box.

Additional Information:
Works in netscape.
Comment 1 Bernhard Rosenkraenzer 2001-05-03 05:26:32 EDT
Yuck... They're using JavaScript. Konqueror's JavaScript support is not quite 
complete yet.

#include <mandatory/JavaScript/is/evil.h>

This is almost certainly the same problem that prevents the "Easy Bug Entry 
Form" in Bugzilla from working.
Comment 2 Bernhard Rosenkraenzer 2001-05-03 05:49:26 EDT
Ok, I've debugged this further. It's bad HTML Netscape handles because it's 
broken.

The HTML code says

<script language="JavaScript" src="/network/help_plus_slotter.js ">

(note the trailing space), so Konqueror tries to get the file along with the 
space, which of course doesn't exist, therefore it doesn't execute any of the 
JavaScript code. The same bug is present in almost all other RHN web pages.

I'll put a workaround into kdelibs because RHN is probably not the only site 
with buggy HTML code, but the right fix would be to fix up RHN.
Comment 3 Bernhard Rosenkraenzer 2001-05-03 12:06:42 EDT
Fixed in 2.2-0.cvs20010503.1


Note You need to log in before you can comment on or make changes to this bug.