Bug 388991 - Kernel oops while playing sound
Kernel oops while playing sound
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
8
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-17 17:57 EST by Kostas Georgiou
Modified: 2007-12-03 14:45 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-03 14:45:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
kernel oops (4.16 KB, text/plain)
2007-11-17 17:57 EST, Kostas Georgiou
no flags Details
lspci -vvxxx output (38.72 KB, text/plain)
2007-11-17 17:59 EST, Kostas Georgiou
no flags Details

  None (edit)
Description Kostas Georgiou 2007-11-17 17:57:14 EST
kernel-2.6.23.1-49.fc8.x86_64 gets an oops while playing sound (both times
it happened while using mythtv). The sound continues to play fine but the sound
can not be controlled anymore and the player never exits and stays in a defunct
state.

I am attaching the stack trace with the oops
Comment 1 Kostas Georgiou 2007-11-17 17:57:14 EST
Created attachment 262561 [details]
kernel oops
Comment 2 Kostas Georgiou 2007-11-17 17:59:02 EST
Created attachment 262571 [details]
lspci -vvxxx output

lspci output attached, let me know if anything else is needed.
Comment 3 Chuck Ebbert 2007-11-21 15:03:16 EST
Try re-running sound card detection. Some devices may have changed configuration
in the kernel update.
Comment 4 Kostas Georgiou 2007-11-22 08:02:59 EST
It is the right card, the same card is detected again. I noticed that due to a
missconfiguration mythtv used oss instead of alsa. Switching to alsa seems to
have cured the problem although I use the laptop very rarely to be certain yet.

Since nobody probably uses oss anymore the issue is really minor so it probably
doesn't worth spending any time on it unless the fix is trivial.
Comment 5 Will Woods 2007-12-03 14:45:30 EST
Yep, OSS has been deprecated since 2004 or so. Glad it seems to be working with
ALSA. Feel free to reopen this bug if the problem persists when using ALSA.

Note You need to log in before you can comment on or make changes to this bug.