Bug 38910 - Token Ring driver not loading
Token Ring driver not loading
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-05-03 06:56 EDT by Mark Oakley
Modified: 2007-04-18 12:33 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-06 08:09:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Mark Oakley 2001-05-03 06:56:14 EDT
Description of Problem:
Unable to install the ibmtr driver

How Reproducible:
insmod ibmtr

Steps to Reproduce:
1. 
2. 
3. 

Actual Results:


Expected Results:


Additional Information:

I have a machine that quite happily did a network install using Token Ring.
Using the same machine I could not install 7.1 - failed to load the driver.

Stuck an Ethernet card in the machine so I could at least see 7.1. Then 
tried to configure the network card but without success:-

May  3 10:36:42 morpheus kernel: tr0: ibmtr_probe1(): unhappy that inb
(0xA20) == 0xFF, Hardware Problem?
May  3 10:36:42 morpheus kernel: tr0: ibmtr_probe1(): unhappy that inb
(0xA24) == 0xFF, Hardware Problem?
May  3 10:36:42 morpheus kernel: ibmtr: register_trdev() returned non-zero.
May  3 10:36:42 morpheus insmod: /lib/modules/2.4.2-
2/kernel/drivers/net/tokenring/ibmtr.o: init_module: Input/output error
May  3 10:36:42 morpheus insmod: Hint: insmod errors can be caused by 
incorrect module parameters, including invalid IO or IRQ parameters
May  3 10:36:42 morpheus insmod: /lib/modules/2.4.2-
2/kernel/drivers/net/tokenring/ibmtr.o: insmod tr0 failed

hwconf contains:-
class: UNSPEC
bus: ISAPNP
detached: 0
driver: unknown
desc: "IBM Turbo 16/4 Token-Ring ISA Adapter:IBM Turbo 16/4 Token-Ring ISA 
Adapter"
deviceId: IBM0000
pdeviceId: IBM1080
native: 0
active: 0
cardnum: 1
logdev: 0
io: 0xa20,0x2f7
irq: 11
mem: 0xc8002ff,0xcc00200
Comment 1 Trond Eivind Glomsrxd 2001-05-03 08:33:28 EDT
Not a 4Suite problem...reassigning
Comment 2 Arjan van de Ven 2001-05-03 08:37:31 EDT
There is a newer version of the tokenring-driver in the current
rawhide kernel. Are you in a position to try that one ?
Comment 3 Arjan van de Ven 2001-05-03 08:40:01 EDT
One more thing: are you using any module-options for the card?
Comment 4 Mark Oakley 2001-05-03 08:47:38 EDT
Nope - no module options specified. It is exactly as the install discs left it.
Comment 5 Mike Phillips 2001-05-03 09:50:26 EDT
This is due to isapnp support being turned on in the kernel. The isa ibmtr 
adapters are configured using lanaid to be pure isa adapters. isapnp then goes 
and detects the card and tries to set it up, ruining the adapters setting. 
Recompiling the kernel without isapnp support will fix this.

I'm working on support for this and a shed load of other fixes for 
ibmtr/ibmtr_cs for the 2.4 kernels.

Mike Phillips
ibmtr/ibmtr_cs maintainer
Comment 6 Mike Phillips 2001-05-14 14:39:45 EDT
Right this turned out to be a bug in the driver itself. (But then when you take
beta code and ship it ;). The corrected driver is available from the web site
(http://www.linuxtr.net). You'll need at least kernel 2.4.4 and preferable
2.4.4-ac9. 

Mike Phillips

Note You need to log in before you can comment on or make changes to this bug.