Bug 389301 - Cannot launch installer on a PlayStation 3
Cannot launch installer on a PlayStation 3
Status: CLOSED DUPLICATE of bug 374201
Product: Fedora
Classification: Fedora
Component: rhpxl (Show other bugs)
8
ppc64 Linux
low Severity medium
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-18 07:19 EST by Julio Merino
Modified: 2008-01-03 19:32 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-03 19:32:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Julio Merino 2007-11-18 07:19:19 EST
I have just tried to install the final version of Fedora 8 ppc on a PlayStation
3 and the installer does not work at all.  The specific machine I have is the
European version of the PS3, with a 60GB hard disk and with WiFi support.

I boot the installer by using the command 'linux64 text' from the kboot's prompt
and get the PAL 576i video mode because the machine is connected with the
default cable shipped with it to a flat screen (this cable is the one with one
component for video and two for audio outputs).  I do not want to use the
graphical installer for performance reasons, but I also tried booting it with
'linux64'.  Same results, unfortunately.

The thing is I get to the installer screen where I'm offered the possibility of
sanity-checking the DVD (and I did and it is OK).  After that step, the
installer tries to run anaconda at which point fails with the following message:

---- cut here ----
Running anaconda 11.3.0.50, the Fedora system installer - please wait...
Traceback (most recent call last):
  File "/usr/bin/anaconda", line 779, in <module>
    floppyDevice = probeHW(opts, x_already_set, xserver)
  File "/usr/bin/anaconda", line 421, in probeHW
    xserver.probeHW(skipMouseProbe=skipmouseprobe, forceDriver=opts.xdriver)
  File "/usr/lib/python2.5/site-packages/rhpxl/xserver.py", line 87, in probeHW
    self.videohw = videocard.VideoCardInfo(forceDriver=forceDriver)
  File "/usr/lib/python2.5/site-packages/rhpxl/videocard.py", line 149, in __init__
    elif os.uname()[4].count("ppc") > 0 and card.pcidom > 0:
AttributeError: device instance has no attribute 'pcidom'
install exited abnormally [1/1]
sending termination signals...done
sending kill signals...done
disabling swap...
unmounting filesystems...
        [list of file systems omitted]
you may safely reboot your system
---- cut here ----

For what is worth, the Fedora 8 RC3 ppc installation image worked fine.  (It had
its own problems after installation, but anaconda ran flawlessly.)

As a workaround, I tried booting with 'linux64 xdriver=fbdev text' as some
reader in my blog suggested, and I got the installer to work.  Pity it doesn't
work by default, though...  Given that there is a workaround, I'm filling this
as medium severity only.
Comment 1 David Woodhouse 2008-01-03 19:32:21 EST

*** This bug has been marked as a duplicate of 374201 ***

Note You need to log in before you can comment on or make changes to this bug.