Bug 389341 - Problem with X11 DPI set too high by Fedora8
Problem with X11 DPI set too high by Fedora8
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
8
i386 Linux
low Severity high
: ---
: ---
Assigned To: Dave Airlie
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-18 08:25 EST by Pakhom
Modified: 2009-01-09 02:27 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-09 02:27:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Log file (45.53 KB, text/plain)
2007-11-18 08:25 EST, Pakhom
no flags Details
Many windows as big (display lock windows and other). (647.94 KB, image/png)
2007-11-18 08:35 EST, Pakhom
no flags Details
Default xorg.conf (864 bytes, application/octet-stream)
2007-11-18 08:38 EST, Pakhom
no flags Details
Current xorg.conf (1.36 KB, application/octet-stream)
2007-11-18 08:39 EST, Pakhom
no flags Details

  None (edit)
Description Pakhom 2007-11-18 08:25:46 EST
Description of problem:
I am was installing FC8 on laptop IBM T60 (ATI Technologies Inc Radeon Mobility
X1400, 1400x1050) and I have a problem:
Many fonts appear too big because for some reason my DPI is set to 122x126 dots
per inch, instead of 96x96.
I've tried editing /etc/X11/xorg.conf like some threads but there is no
"monitor" section so I tried chose other the Generic Monitor "LCD Panel
1400x1050" and reboot. So problem still the same. Then I try to add "DisplaySize
370 277" in /etc/X11/xorg.conf threads "monitor" and reboot. So problem still
the same.

Even /etc/X11/Xresources has the line
Xft.dpi: 96.

Until editing xorg.conf
xdpyinfo | grep -B1 dot
dimensions: 1400x1050 pixels (291x212 millimeters)
resolution: 122x126 dots per inch

After:
xdpyinfo | grep -B1 dot
dimensions: 1400x1050 pixels (370x278 millimeters)
resolution: 96x96 dots per inch

xorg.conf:
Section "Monitor"
Identifier "Monitor0"
ModelName "LCD Panel 1400x1050"
DisplaySize 370 277
HorizSync 31.5 - 65.5
VertRefresh 56.0 - 65.0
Option "dpms"
EndSection

Version-Release number of selected component (if applicable):
Linux localhost.localdomain 2.6.23.1-49.fc8 #1 SMP Thu Nov 8 21:41:26 EST 2007
i686 i686 i386 GNU/Linux



How reproducible:


Steps to Reproduce:
1.installing FC8 on laptop IBM T60 (ATI Technologies Inc Radeon Mobility X1400,
1400x1050)
2. Choose display resolution 1400x1050
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Pakhom 2007-11-18 08:25:46 EST
Created attachment 262871 [details]
Log file
Comment 2 Pakhom 2007-11-18 08:35:38 EST
Created attachment 262891 [details]
Many windows as big (display lock windows and other).
Comment 3 Pakhom 2007-11-18 08:38:18 EST
Created attachment 262901 [details]
Default xorg.conf
Comment 4 Pakhom 2007-11-18 08:39:25 EST
Created attachment 262911 [details]
Current xorg.conf
Comment 5 Pakhom 2007-11-18 15:11:51 EST
I am try to install KDE and problem is not reproducing. The problem is
reproducing only with Gnome.
Comment 6 Pakhom 2007-11-19 00:25:19 EST
I found a workaround:
In xorg.conf I remove string DisplaySize 370 278 ->restart X -> chose is gnome
settings (gnome-appearance-properties) 96dpi -> save -> reboot -> add in
xorg.conf DisplaySize 370 278. 
Comment 7 François Kooman 2008-04-08 08:43:34 EDT
On my screen:

[fkooman@dilithium ~]$ xdpyinfo | grep -B1 dot
  dimensions:    1440x900 pixels (303x190 millimeters)
  resolution:    121x120 dots per inch
[fkooman@dilithium ~]$ cat /var/log/Xorg.0.log | grep -i dpi
(==) intel(0): DPI set to (100, 100)
[fkooman@dilithium ~]$ 

I didn't tweak anything in xorg.conf for the DPI settings. It seems to be OK in
gdm, but not in GNOME. Setting the dpi at the font selection things in GNOME to
100 makes it look really nice. 96 is also an option, but 100 seems nicer. So it
looks like the Intel driver does a sane thing by "setting" it to 100, no idea
why xdpyinfo shows 121x120 though.
Comment 8 Bug Zapper 2008-11-26 03:33:14 EST
This message is a reminder that Fedora 8 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 8.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '8'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 8's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 8 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 9 Bug Zapper 2009-01-09 02:27:16 EST
Fedora 8 changed to end-of-life (EOL) status on 2009-01-07. Fedora 8 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.