Bug 389401 - cannot get nfs shares to mount on boot
cannot get nfs shares to mount on boot
Status: CLOSED DUPLICATE of bug 427157
Product: Fedora
Classification: Fedora
Component: initscripts (Show other bugs)
i386 Linux
low Severity low
: ---
: ---
Assigned To: Bill Nottingham
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2007-11-18 09:47 EST by Mark
Modified: 2014-03-16 23:11 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-01-07 14:43:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Mark 2007-11-18 09:47:49 EST
adding mount commands to the /etc/fstab do not run and therefore won't mount my
nfs shares on boot.


adding mount commands to /etc/rc.d/rc.local do not run and therefore won't mount
nfs shares on boot

How reproducible:
Added these commands to fstab: /mnt/fileserver	nfs	defaults	0	0 /mnt/fileserver2 nfs	defaults	0	0

added these to rc.local
/bin/mount -t nfs /mnt/fileserver
/bin/mount -t nfs /mnt/fileserver2
Actual results:
The mounts do not accur during boot with either  of the above methods

Expected results:
nfs shares should be mountable during the boot sequence
Comment 1 Bill Nottingham 2007-11-19 16:41:02 EST
In what way do they not mount? Is rpcbind and nfslock started?
Comment 2 Mark 2007-11-19 20:19:20 EST
rpcbind and nfslock are both running.

They don't mount after bootup.  Not sure there are more ways to describe.  They
are either mounted or unmounted.  
Comment 3 Bill Nottingham 2007-11-20 11:31:39 EST
Does 'mount -a -t nfs' work?
Comment 4 Mark 2007-11-20 20:02:06 EST
Yes.  Running the mount command from command prompt after bootup works fine. 
Also, if i put the mount commands in the rc.local, i can run the rc.local file
from the command prompt (/etc/rc.d/./rc.local) and it work fine.

So the issue is on bootup only.  Is this perhaps a problem due to me starting
with Fedora 8 RC3 and then upgrading to the final?  Some startup script file out
of wack?

I'm at a loss here.
Comment 5 Bill Nottingham 2007-11-21 10:48:08 EST
Any SELinux errors in /var/log/audit/audit.log, or dmesg?
Comment 6 Bill Nottingham 2007-11-21 11:08:22 EST
I've done a test here; adding an entry in fstab seems to work OK - it's mounted
correctly by netfs.
Comment 7 Mark 2007-11-21 18:01:25 EST
SELinux is off.
Comment 8 Trevor Cordes 2007-11-24 08:31:11 EST
Explicitly add the options bg,hard,intr to your fstab line.  Hard will force it
to keep retrying until it mounts.  Bg will allow mount to go on while it keeps
trying in the bg.  Not the best fix, but it should allow it to automount the
instant your boot process is done enough to let it.

Check any iptables scripts that might be blocking the ports until the boot is
done.  Also, if you want some fun, migrate to NFSv4 and tcp.

BTW, works fine for me on F8.
Comment 9 Mark 2008-01-01 19:19:17 EST
Resolved:  see this bug report for resolution.
Comment 10 Bill Nottingham 2008-01-07 14:43:56 EST

*** This bug has been marked as a duplicate of 427157 ***

Note You need to log in before you can comment on or make changes to this bug.