Bug 389431 - App stuck on first run
App stuck on first run
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: PyOpenGL (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Hans de Goede
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-18 10:33 EST by Alexey Kuznetsov
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-20 15:55:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Stuck example application (1.37 KB, text/x-python)
2007-11-18 10:33 EST, Alexey Kuznetsov
no flags Details

  None (edit)
Description Alexey Kuznetsov 2007-11-18 10:33:23 EST
Description of problem:
When i try to run small opengl app, it get stucked. Any other OpenGl application
work fine.

Version-Release number of selected component (if applicable):
PyOpenGL-3.0.0-0.4.a6.fc8
xorg-x11-server-Xorg-1.3.0.0-33.fc8

How reproducible:
all time

Steps to Reproduce:
1. restart X server
2. run bug.py
3. run bug.py again to unstuck both application
Comment 1 Alexey Kuznetsov 2007-11-18 10:33:23 EST
Created attachment 262951 [details]
Stuck example application
Comment 2 Hans de Goede 2007-11-20 15:55:35 EST
I cannot reproduce this on my x86_64 machine with a radeon 9800pro.

Also, the bug.py application seems rather buggy itself, calling gtk.main_quit()
on expose (iow quiting immediately after startup), setting windowsize to 0x0 etc.

Closing as not a bug, certainly not a PyOpenGL bug as that doesn't touch
anything like threads, etc. Might be a mesa bug and only happen on certain
hardware though, but first I would take a really good look at your own code.
Comment 3 Alexey Kuznetsov 2007-11-20 16:01:08 EST
That 100% reproducible at propriatirary ati drivers, u can get stuck with out
gtk.main() or gtk.main_quit() i put it here for example
Comment 4 Hans de Goede 2007-11-20 16:05:41 EST
Well, file a bug with ATI/AMD then.
Comment 5 Alexey Kuznetsov 2007-11-20 16:32:46 EST
Probably u right, i run test on fedora 7 installation, everything work fine. I
have trouble only with fedora 8, look like it a kernel or ati drivers bug...

Note You need to log in before you can comment on or make changes to this bug.