Bug 389521 - Unstable sound, FC8, kernel: codec_read 0: semaphore is not ready for register 0x2c
Unstable sound, FC8, kernel: codec_read 0: semaphore is not ready for registe...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
8
i386 Linux
low Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-18 12:38 EST by Wolfgang Rauchholz
Modified: 2008-01-14 05:35 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-29 16:43:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
system messages file (576.10 KB, application/octet-stream)
2007-11-18 12:38 EST, Wolfgang Rauchholz
no flags Details

  None (edit)
Description Wolfgang Rauchholz 2007-11-18 12:38:03 EST
Description of problem:
When booting the computer , sometimes the sound works and sometimes not.
I run FC8 on a Fujitsu Siemens Amilo 1425 Laptop.
lpsci gives me:
00:00.0 Host bridge: Intel Corporation 82855PM Processor to I/O Controller (rev 21)
00:01.0 PCI bridge: Intel Corporation 82855PM Processor to AGP Controller (rev 21)
00:1d.0 USB Controller: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M)
USB UHCI Controller #1 (rev 03)
00:1d.1 USB Controller: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M)
USB UHCI Controller #2 (rev 03)
00:1d.2 USB Controller: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M)
USB UHCI Controller #3 (rev 03)
00:1d.7 USB Controller: Intel Corporation 82801DB/DBM (ICH4/ICH4-M) USB2 EHCI
Controller (rev 03)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev 83)
00:1f.0 ISA bridge: Intel Corporation 82801DBM (ICH4-M) LPC Interface Bridge
(rev 03)
00:1f.1 IDE interface: Intel Corporation 82801DBM (ICH4-M) IDE Controller (rev 03)
00:1f.3 SMBus: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) SMBus
Controller (rev 03)
00:1f.5 Multimedia audio controller: Intel Corporation 82801DB/DBL/DBM
(ICH4/ICH4-L/ICH4-M) AC'97 Audio Controller (rev 03)
00:1f.6 Modem: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) AC'97
Modem Controller (rev 03)
01:00.0 VGA compatible controller: ATI Technologies Inc RV350 [Mobility Radeon
9600 M10]
02:09.0 FireWire (IEEE 1394): Texas Instruments TSB43AB22/A IEEE-1394a-2000
Controller (PHY/Link)
02:0a.0 Ethernet controller: Realtek Semiconductor Co., Ltd.
RTL-8139/8139C/8139C+ (rev 10)
02:0b.0 CardBus bridge: O2 Micro, Inc. OZ711M1/MC1 4-in-1 MemoryCardBus
Controller (rev 20)
02:0b.1 CardBus bridge: O2 Micro, Inc. OZ711M1/MC1 4-in-1 MemoryCardBus
Controller (rev 20)
02:0b.2 System peripheral: O2 Micro, Inc. OZ711Mx 4-in-1 MemoryCardBus Accelerator
02:0d.0 Network controller: Intel Corporation PRO/Wireless 2200BG Network
Connection (rev 05)

I found the following in /var/log/messages:
When sound works:
Nov 18 18:16:14 MGPRJRWR kernel: intel8x0_measure_ac97_clock: measured 50992 usecs
Nov 18 18:16:14 MGPRJRWR kernel: intel8x0: clocking to 48000
Nov 18 18:16:14 MGPRJRWR kernel: NET: Registered protocol family 10

When sound does not work:
Nov 18 12:26:30 MGPRJRWR kernel: intel8x0_measure_ac97_clock: measured 50023 usecs
Nov 18 12:26:30 MGPRJRWR kernel: intel8x0: clocking to 48000
Nov 18 12:26:30 MGPRJRWR kernel: Unable to initialize codec #0

When sound does not work and I try ther system to detect the soundcard:
Nov 18 12:28:01 MGPRJRWR kernel: codec_read 0: semaphore is not ready for
register 0x2c

Version-Release number of selected component (if applicable): Fedora Core 8


How reproducible:
Re-boooting the computer


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Wolfgang Rauchholz 2007-11-18 12:38:03 EST
Created attachment 263001 [details]
system messages file
Comment 2 Martin Stransky 2007-11-26 17:13:27 EST
Reassigned to kernel.

Anyway, please consider to report it to ALSA project (www.alsa-project.org),
they're authors of ALSA linux sound system.
Comment 3 Wolfgang Rauchholz 2007-11-27 15:19:54 EST
I forgot initially to tell that sound worked stable under Ubuntu 7.x
I made some further investigation using the script:
http://bulletproof.servebeer.com/alsa/scripts/alsa-info.sh
which lists also the loaded modules. When sound is not working, there are 4
modules not loaded: vfat, fat, usb_storage and usblp
Comment 4 Chuck Ebbert 2007-11-27 16:28:11 EST
Please attach the contents of /etc/modprobe.conf to this bugzilla.
Comment 5 Wolfgang Rauchholz 2007-11-28 02:59:29 EST
Booted the computer and I can hear no sound.
I went to sound card detection and played the test sound with known result; no
sound. The screen shows the following info:
Vendor: Intel Corporation
Model: 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) AC'97 Audio Controller (rev 03)
Module: snd-intel8x0
...
PCM device: Intel 82801DB-ICH4


1. alsamixer
Card: PulseAudio
Chip: PulseAudio
View: [Playback] Capture All
Item: Master

There is one bar in the center of the screen. From the bottom to top the values are:
<Master>, 65<>65, 00
The channel is not muted.

2.
[root@MGPRJRWR ~]# /sbin/lsusb
Bus 001 Device 001: ID 0000:0000 
Bus 004 Device 001: ID 0000:0000 
Bus 003 Device 001: ID 0000:0000 
Bus 002 Device 002: ID 046d:c517 Logitech, Inc.
Bus 002 Device 001: ID 0000:0000

3.
[root@MGPRJRWR ~]# yum install alsa-lib
Setting up Install Process
Parsing package install arguments
Package alsa-lib - 1.0.15-1.fc8.i386 is already installed.
Nothing to do

[root@MGPRJRWR ~]# rpm -q alsa-lib
alsa-lib-1.0.15-1.fc8

4.
[root@MGPRJRWR ~]# aplay /usr/lib/firefox-2.0.0.9/res/samples/test.wav
Playing WAVE '/usr/lib/firefox- 2.0.0.9/res/samples/test.wav' : Unsigned 8 bit,
Rate 22050 Hz, Mono
[root@MGPRJRWR ~]# aplay /usr/lib/openoffice.org/share/gallery/sounds/horse.wav
Playing WAVE '/usr/lib/openoffice.org/share/gallery/sounds/horse.wav' : Signed
16 bit Little Endian, Rate 11025 Hz, Mono

.....but I hear no no sound

5.
[root@MGPRJRWR ~]# more /etc/modprobe.conf

alias eth0 8139too
alias scsi_hostadapter libata
alias scsi_hostadapter1 ata_piix
alias eth1 ipw2200
alias snd-card-0 snd-intel8x0
options snd-card-0 index=0
options snd-intel8x0 index=0

6.
[root@MGPRJRWR ~]# cat /proc/asound/cards

 0 [I82801DBICH4   ]: ICH4 - Intel 82801DB-ICH4
                      Intel 82801DB-ICH4 with VIA1612A at irq 9



7. extract from /vat/log/messages
...
Nov 28 08:13:27 MGPRJRWR kernel: agpgart: Detected an Intel 855PM Chipset.
...
Nov 28 08:13:27 MGPRJRWR kernel: intel_rng: FWH not detected
...
Nov 28 08:13:27 MGPRJRWR kernel: intel8x0_measure_ac97_clock: measured 50940 usecs
Nov 28 08:13:27 MGPRJRWR kernel: intel8x0: clocking to 48000
Nov 28 08:13:27 MGPRJRWR kernel: Unable to initialize codec #0




But I also found these messages in the same file
Nov 28 08:28:04 MGPRJRWR kernel: codec_write 0: semaphore is not ready for
register 0x2
Nov 28 08:28:05 MGPRJRWR kernel: codec_write 0: semaphore is not ready for
register 0x2
Nov 28 08:30:55 MGPRJRWR kernel: codec_write 0: semaphore is not ready for
register 0x2
Nov 28 08:30:55 MGPRJRWR kernel: codec_write 0: semaphore is not ready for
register 0x2
Nov 28 08:30:56 MGPRJRWR kernel: codec_read 0: semaphore is not ready for
register 0x2c
Nov 28 08:38:19 MGPRJRWR pulseaudio[2264]: module-alsa-sink.c: Error opening PCM
device hw:0: Device or resource busy
Nov 28 08:38:36 MGPRJRWR pulseaudio[2264]: module-alsa-sink.c: Error opening PCM
device hw:0: Device or resource busy
Nov 28 08:54:04 MGPRJRWR kernel: codec_read 0: semaphore is not ready for
register 0x2c


Nov 28 08:54:04 MGPRJRWR kernel: codec_read 0: semaphore is not ready for
register 0x2c; this record was created when plying the the test sound in sound
card detection.
Comment 6 Chuck Ebbert 2007-11-28 17:29:53 EST
Can you try blacklisting the modem driver? Just add the following line to
/etc/modprobe.d/blacklist:

blacklist snd-intel8x0m

Comment 7 Wolfgang Rauchholz 2007-11-29 16:12:31 EST
Made this change and booted the laptop 10 times aprox. Sound was always working.
Seems to have fixed the problem. Thanks
Comment 8 Chuck Ebbert 2007-11-29 16:43:54 EST
The modem needs to be loaded after the sound driver for everything to work
properly. So if you want to use the modem this should work instead (all on one
line in modprobe.conf):

 install snd-intel8x0m { /sbin/modprobe snd-intel8x0; } ; /sbin/modprobe
--first-time --ignore-install snd-intel8x0m

Closing as not a bug since it's a config issue.
Comment 9 Hans de Goede 2008-01-14 05:35:19 EST
(In reply to comment #8)
> The modem needs to be loaded after the sound driver for everything to work
> properly. So if you want to use the modem this should work instead (all on one
> line in modprobe.conf):
> 
>  install snd-intel8x0m { /sbin/modprobe snd-intel8x0; } ; /sbin/modprobe
> --first-time --ignore-install snd-intel8x0m
> 
> Closing as not a bug since it's a config issue.

Short intro: I'm a Fedora contributer doing some kernel bug triaging,

Chuck I don't think that closing this as not a bug is correct, things do not
work out of the box, so atleast it should be reassigned to another Fedora
component to get properly fixed there.

Also if snd-intel8x0m must always be loaded after snd-intel8x0, then I believe
this is best fixed in the kernel, by making snd-intel8x0m depend on a symbol
defined in snd-intel8x0, or am I thinking to simple here?

Note You need to log in before you can comment on or make changes to this bug.