Bug 38954 - date --rfc-822 incorrectly follows i18n settings
Summary: date --rfc-822 incorrectly follows i18n settings
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: sh-utils   
(Show other bugs)
Version: 7.1
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bernhard Rosenkraenzer
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-05-03 14:46 UTC by Daniel Roesen
Modified: 2007-04-18 16:33 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-03 14:46:30 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Daniel Roesen 2001-05-03 14:46:26 UTC
$ LANG=de_DE date --rfc-822
Don,  3 Mai 2001 16:43:55 +0200

RFC 822 (and the successor 2822) is clear that only english words for day
and month are valid. So date should never use i18n maps if -R/--rfc-822 is
used because it generates non-compliant date strings.

Comment 1 Bernhard Rosenkraenzer 2001-05-04 14:08:13 UTC
Fixed in 2.0-14.



Note You need to log in before you can comment on or make changes to this bug.