Bug 38956 - KDE logout hangs if Netscape running
KDE logout hangs if Netscape running
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: netscape (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-05-03 11:05 EDT by ken_laird
Modified: 2007-04-18 12:33 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-03 11:05:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description ken_laird 2001-05-03 11:05:03 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.75 [en] (X11; U; Linux 2.2.14-5.0smp i686)

Description of problem:
We are seeing an intermittent behavior where KDE's session saving step will
hang if an instance of the Netscape browser is running.  We have not been
able to characterize the problem further.  It  does not seem to be specific
to any given user or machine.

How reproducible:
Sometimes

Steps to Reproduce:
1.  Login to KDE.
2.  Start Netscape and wait until it has gone to its designated home page.
3. Logout of KDE. 
	

Actual Results:  Sometimes KDE will hang trying to preserve the session.

Expected Results:  It should always exit cleanly.

Additional info:

The workaround is that someone with root capability rlogin's to the
affected machine and stops and restarts the X server.  We haven't tried
killing Netscape to see if that would allow KDE to finish shutting down.
Comment 1 Bernhard Rosenkraenzer 2001-05-03 11:14:39 EDT
Known Netscape bug (it handles session management commands, but doesn't get it 
right). Since we don't have access to the source, we can't fix this - use 
Konqueror or Mozilla.
Comment 2 ken_laird 2001-05-03 12:16:57 EDT
Does this problem continue with the 4.76 release of Netscape that is shipped
with Redhat 7.1?
Comment 3 Bernhard Rosenkraenzer 2001-05-03 12:23:59 EDT
Probably. I haven't bothered to check out Netscape ever since Konqueror 
started to work better than it (for me).

Note You need to log in before you can comment on or make changes to this bug.