Bug 389681 - pulseaudio does not play (nice) with isa sb16
pulseaudio does not play (nice) with isa sb16
Status: CLOSED DUPLICATE of bug 370821
Product: Fedora
Classification: Fedora
Component: hal (Show other bugs)
i686 Linux
low Severity low
: ---
: ---
Assigned To: David Zeuthen
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2007-11-18 14:46 EST by Adam Pribyl
Modified: 2013-03-05 22:53 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2007-11-30 13:03:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Adam Pribyl 2007-11-18 14:46:09 EST
Description of problem:
Pulseaudio totaly fails if the card is sb16 via ISA bus (=needs manualy loading
After update form F7 the card was detected and used, but pavucontrol sigsegv.
After some fidling around the alsa configurations ware rewritten and now even
alsa does not see the card. It's however still possible to load sucessfully the

Version-Release number of selected component (if applicable):
------- rpm -q alsa-lib --------

------- rpm -q alsa-utils --------
Comment 1 Adam Pribyl 2007-11-26 15:56:46 EST
The problem seems to come from hal. Because lshal does not lists all appropriate
lshal | grep alsa
udi = '/org/freedesktop/Hal/devices/computer_alsa_timer'
  alsa.device_file = '/dev/snd/timer'  (string)
  alsa.type = 'timer'  (string)
  info.capabilities = {'alsa', 'access_control'} (string list)
  info.category = 'alsa'  (string)
  info.udi = '/org/freedesktop/Hal/devices/computer_alsa_timer'  (string)
udi = '/org/freedesktop/Hal/devices/computer_alsa_sequencer'
  alsa.device_file = '/dev/snd/seq'  (string)
  alsa.type = 'sequencer'  (string)
  info.capabilities = {'alsa', 'access_control'} (string list)
  info.category = 'alsa'  (string)
  info.udi = '/org/freedesktop/Hal/devices/computer_alsa_sequencer'  (string)

For that reason it also does not change the device permissions and users do not
have access to them. This was revealed when I removed alsa-plugins-pulseaudio. 

However the pavucontrol still sigsegvs, so there is still some problem with
pulseaudio too.
Comment 2 Lennart Poettering 2007-11-29 19:22:13 EST
pavucontrol has a bug which causes it to segfault when no sound card has been
identified. See http://pulseaudio.org/ticket/172 

This will be fixed shortly upstream.

You say the device is properly identified by the kernel but HAL doesn't find it?
This is most likely an issue in the kernel driver, and probably similar to the
issue described in #370821.

I am reassigning this issue to HAL now. David will probably be able to tell you
quickly if this issue is the same as #370821. Please paste the outputs of "tree"
here, similar to those posted in that bug report.

I will ping the guys on the ALSA ML about this, too.
Comment 4 David Zeuthen 2007-11-30 13:03:26 EST

*** This bug has been marked as a duplicate of 370821 ***

Note You need to log in before you can comment on or make changes to this bug.