Bug 389711 - kdetv crashes if the "Settings" button is pressed. Also, missing dependency
kdetv crashes if the "Settings" button is pressed. Also, missing dependency
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kdetv (Show other bugs)
8
i386 Linux
low Severity high
: ---
: ---
Assigned To: Ian Chapman
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-18 15:32 EST by Peter Trenholme
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version: 0.8.9-8.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-26 13:56:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Output from cmd lind invocation (2.71 KB, text/plain)
2007-11-18 15:32 EST, Peter Trenholme
no flags Details

  None (edit)
Description Peter Trenholme 2007-11-18 15:32:13 EST
Description of problem:
If the KDETV application is started, it first complains that it has an ond,
incorrect, version "video_std_set."

More seriously, the application crashes when the "Settings" button is clicked.

Version-Release number of selected component (if applicable):
$ kdetv --version
Qt: 3.3.8
KDE: 3.5.8-7.fc8 Fedora
kdetv: 0.8.9


How reproducible:
Every time, even if run as "root"

Steps to Reproduce:
1.Start application
2.Click on "settings"
3.
  
Actual results:
Crash -- See attachment for listing produced when kdetv is started from a
command line.

Expected results:
Settings dialog

Additional info:
The docbook help file is unusable
Comment 1 Peter Trenholme 2007-11-18 15:32:13 EST
Created attachment 263101 [details]
Output from cmd lind invocation
Comment 2 Ian Chapman 2007-11-23 17:18:55 EST
I believe I've discovered the source of the crash, probably due to recent build
root changes it was missing the alsa plugin, so I've added a dependency on
alsa-lib-devel and will check that solves the problem, but I need some
additional information.

1. What's the missing dependency you refer to?

2. In what way is the docbook help file unusable? I take it your referring to
the KDETV handbook? This works fine for me.
Comment 3 Peter Trenholme 2007-11-24 21:10:04 EST
1) The dependency was, IIRC, the LIRC drivers. Not a real problem since I have
IR stuff disabled for now.

2) The docbook would not load. I just tried it again, and it seems to be working
now, so, again, not a (current) problem. Since I posted the bug, I've installed
MythTV (from source) and installed/upgraded lots of software, so I suppose
something changed.

I was going to try [b]kdetv[/b] from the "development" repository, but the
dependency tree would have required that I install (almost) my whole system from
"development, and I thought that was a bit too much.
Comment 4 Ian Chapman 2007-11-25 12:16:16 EST
(In reply to comment #3)
> 1) The dependency was, IIRC, the LIRC drivers. Not a real problem since I have
> IR stuff disabled for now.

Oh OK, it is currently built against lirc so the problem may have been elsewhere.

> 2) The docbook would not load. I just tried it again, and it seems to be working

No problem.

> I was going to try [b]kdetv[/b] from the "development" repository, but the
> dependency tree would have required that I install (almost) my whole system from
> "development, and I thought that was a bit too much.

Yes and tbh it wouldn't have helped you in this case, kdetv in devel has the
same problem. I'll push an update for devel and F8 shortly which should at least
fix the problem of opening the settings window.
Comment 5 Fedora Update System 2007-11-26 13:56:20 EST
kdetv-0.8.9-8.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 6 Fedora Update System 2007-11-28 20:37:16 EST
kdetv-0.8.9-8.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.