Bug 389801 - pirut crashes when I do a search and then click on the overview (in German Übersicht) tab during it is searching
pirut crashes when I do a search and then click on the overview (in German Üb...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: pirut (Show other bugs)
8
i686 Linux
low Severity low
: ---
: ---
Assigned To: Jeremy Katz
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-18 17:23 EST by Erik Streb del Toro
Modified: 2007-12-31 09:52 EST (History)
1 user (show)

See Also:
Fixed In Version: 1.3.28
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-31 09:52:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
First crash-debug-log (searching for kile or latex). (620 bytes, text/plain)
2007-11-18 17:26 EST, Erik Streb del Toro
no flags Details
Second crash-debug-log (searching for kile). (620 bytes, text/plain)
2007-11-18 17:26 EST, Erik Streb del Toro
no flags Details
Third crash-debug-log (searching for bla). (620 bytes, text/plain)
2007-11-18 17:28 EST, Erik Streb del Toro
no flags Details

  None (edit)
Description Erik Streb del Toro 2007-11-18 17:23:40 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.9) Gecko/20071105 Galeon/2.0.3 Firefox/2.0.0.9

Description of problem:
When I start a search (I testet it for kile, latex and bla in the searchfield) and then click on the tab called Overview (in German it is called Übersicht) during the searchprocess, the pirut-program crashes giving me a debug-file to save (which I will attach).

I did different searches and it always crashed, when I interrupted the search by clicking on the Overview tab. I didn't test the other tab called List.

When I do a normal search without clicking around during searchprocess it succeeds. So I think this is a bug.

Version-Release number of selected component (if applicable):
pirut-1.3.25-2.fc8

How reproducible:
Always


Steps to Reproduce:
1.Search for anything.
2.Click on the Overview tab (in German called Übersicht) during the searchprocess (no problem on my slow computer, which is Pentium 2 with 450 MHz).


Actual Results:
Pirut crashes and debuginfo is offered to save.

Expected Results:
Either the Overview tab should be opened or the program should ignore the click because it is doing a search (not so userfriendly).

Additional info:
Please test clicking on the other tabs or doing anything else during the searchprocess, too. Maybe there are similar situations where this bug appears.
Comment 1 Erik Streb del Toro 2007-11-18 17:26:23 EST
Created attachment 263151 [details]
First crash-debug-log (searching for kile or latex).
Comment 2 Erik Streb del Toro 2007-11-18 17:26:58 EST
Created attachment 263161 [details]
Second crash-debug-log (searching for kile).
Comment 3 Erik Streb del Toro 2007-11-18 17:28:00 EST
Created attachment 263171 [details]
Third crash-debug-log (searching for bla).
Comment 4 Jeremy Katz 2007-11-19 13:46:27 EST
Thanks for the great reproducers.  Fixed in git and will be pushed as an update soon
Comment 5 Fedora Update System 2007-11-20 12:50:06 EST
pirut-1.3.26-1.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update pirut'
Comment 6 Fedora Update System 2007-11-28 20:34:05 EST
pirut-1.3.27-1.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update pirut'
Comment 7 Fedora Update System 2007-12-06 15:45:32 EST
pirut-1.3.28-1.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 8 Fedora Update System 2007-12-06 15:55:10 EST
pirut-1.3.28-1.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 9 Jeremy Katz 2007-12-31 09:52:03 EST
New versions of pirut have been released that should address these issues

Note You need to log in before you can comment on or make changes to this bug.