Bug 389821 - snd-hda-intel does not work after resume from suspend or hibernate
snd-hda-intel does not work after resume from suspend or hibernate
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-18 17:51 EST by Philippe Troin
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-27 16:59:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Philippe Troin 2007-11-18 17:51:28 EST
Description of problem:
snd-hda-intel works after booting.  If the computer is suspended or hibernated,
at resume the alsa device is gone.  Pulseaudio freaks out.
Killing all processes accessing sound devices and removing and inserting the
module make the device reappear.

Version-Release number of selected component (if applicable):
kernel-2.6.23.1-49.fc8.x86_64

How reproducible:
Always.

Steps to Reproduce:
1. Boot
2. Check that sound works (eg. aplay /usr/share/sounds/shutdown1.wav)
3. Suspend or hibernate
4. Resume
5. Try to play sound. 

Actual results:
No sound.

Expected results:
Duh.

Additional info:
This has been tested on two different computers, both of which failed.
One is a Fujitsu P7200 running i386.
The other is a Dell D620 running x86_64.
Comment 1 Philippe Troin 2007-11-27 16:59:38 EST
I cannot reproduce the issue anymore.
It might have been fixed by some other package update.

Phil.

Note You need to log in before you can comment on or make changes to this bug.