Bug 390321 - Missing COPYING or LICENSE file
Missing COPYING or LICENSE file
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: python-virtinst (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Richard W.M. Jones
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-19 08:56 EST by Soren Hansen
Modified: 2008-01-22 10:32 EST (History)
0 users

See Also:
Fixed In Version: 0.300.2-2.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-22 10:32:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Soren Hansen 2007-11-19 08:56:22 EST
Description of problem:

All the source files in the virt-install tarball correctly contains the GPL
license snippet which says "You should have received a copy of the GNU General
Public License[...]"... Sadly, that's not the case :), as the usual LICENSE or
COPYING file is not in the tarball, AFAICS.
Comment 1 Soren Hansen 2007-11-20 05:13:23 EST
Hm.. It seems the problem is a bit more severe. I incorrectly assumed that all
the source files have the correct GPL license snippet, but they don't.

I'd like to request that every source file in the project contain explicit,
unambiguous copyright assignment and licensing information:

The following files suggest that the named people share the copyright with
RedHat,but I'm curious if that's really the case or if they are named there
"just" because they're the authors:
virt-image
virt-install
virtinst/CapabilitiesParser.py
virtinst/cli.py
virtinst/DistroManager.py
virtinst/FullVirtGuest.py
virtinst/Guest.py
virtinst/ImageManager.py
virtinst/ImageParser.py
virtinst/LiveCDInstaller.py
virtinst/ParaVirtGuest.py
virtinst/util.py


The following files do not clearly show which version of the GPL applies to them:
virt-image
virt-install
virtinst/CapabilitiesParser.py
virtinst/cli.py
virtinst/DistroManager.py
virtinst/FullVirtGuest.py
virtinst/Guest.py
virtinst/LiveCDInstaller.py
virtinst/ParaVirtGuest.py
virtinst/util.py

The following files use the old FSF address:
virt-clone
virt-image
virt-install
virtinst/CapabilitiesParser.py
virtinst/cli.py
virtinst/CloneManager.py
virtinst/DistroManager.py
virtinst/FullVirtGuest.py
virtinst/Guest.py
virtinst/LiveCDInstaller.py
virtinst/ParaVirtGuest.py
virtinst/util.py


The following files don't state which license applies to them at all:
setup.py
virtinst/ImageManager.py
virtinst/ImageParser.py
virtinst/__init__.py
tests/capabilities.py
tests/xmlconfig.py
tests/image.py


The following files don't state who has the copyright at all:
setup.py
virtinst/__init__.py
tests/capabilities.py
tests/xmlconfig.py
tests/image.py


I would have loved to have provided a patch to fix all of this, but that would
require me to actually know which license and copyright actually should be
applied to each file. :)
Comment 2 Daniel Berrange 2007-11-20 07:10:55 EST
The names are all author names. The Copyright is either Red Hat, or Fujitsu. The
Fujitsu files had correct GPLv2+ headers on the source. I have committed changes
upstream to clarify the Red Hat source files in the same way, and also fixed the
outdated FSF address.

http://hg.et.redhat.com/virt/applications/virtinst--devel?cs=2215263e8a23
Comment 3 Fedora Update System 2008-01-11 17:28:00 EST
python-virtinst-0.300.2-2.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update python-virtinst'
Comment 4 Fedora Update System 2008-01-22 10:32:30 EST
python-virtinst-0.300.2-2.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.