Bug 390431 - Printer Icon not functional - /usr/share/system-config-printer/applet.py
Printer Icon not functional - /usr/share/system-config-printer/applet.py
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: system-config-printer (Show other bugs)
8
i386 Linux
low Severity low
: ---
: ---
Assigned To: Tim Waugh
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F8Target
  Show dependency treegraph
 
Reported: 2007-11-19 09:24 EST by Stefan Jensen
Modified: 2008-01-29 00:17 EST (History)
0 users

See Also:
Fixed In Version: 0.7.74.10-2.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-29 00:15:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stefan Jensen 2007-11-19 09:24:30 EST
Description of problem:

Printer Applet doesn't showed up in Gnome

~/.xsession-errors

Traceback (most recent call last):
  File "/usr/share/system-config-printer/applet.py", line 1060, in <module>
    bus.remove_signal_receiver (check_for_jobs,
NameError: name 'check_for_jobs' is not defined

Starting /usr/bin/system-config-printer-applet --no-tray-icon runs fine.

Version-Release number of selected component (if applicable):

system-config-printer-0.7.74.5-1.fc8
system-config-printer-libs-0.7.74.5-1.fc8

How reproducible:

Always

Steps to Reproduce:
  
Actual results:

Printer status icon does not appears.

Expected results:

Printer status icon appears

Additional info:

none.
Comment 1 Tim Waugh 2007-11-19 10:12:46 EST
Thanks for the report.  I've fixed this now in SVN so will make a new test
update soon.
Comment 2 Fedora Update System 2007-11-20 12:47:04 EST
system-config-printer-0.7.74.6-1.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update system-config-printer'
Comment 3 Fedora Update System 2007-11-20 13:07:27 EST
system-config-printer-0.7.74.6-1.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update system-config-printer'
Comment 4 Stefan Jensen 2007-11-20 18:47:11 EST
(In reply to comment #2)
> system-config-printer-0.7.74.6-1.fc8 has been pushed to the Fedora 8 testing
repository.  If problems still persist, please make note of it in this bug report.
>  If you want to test the update, you can install it with 
>  su -c 'yum --enablerepo=updates-testing update system-config-printer'

installed the new packages, an the status icon is now ok. But now, when i want
to print a "print test page" from system-config-printer it gives me a seqfault:

"Nov 21 00:40:01 hurricane kernel: python[3848]: segfault at 00000007 eip
00b58bc8 esp bfab69ac error 4"

Normal printing from firefox or whatever program works fine.

Greetings

Stefan
--
Comment 5 Tim Waugh 2007-11-21 07:41:47 EST
Oh, I think I see the problem.  I've built 0.7.74.6-2 now to address it; coming
to updates-testing soon.
Comment 6 Fedora Update System 2007-11-21 22:34:13 EST
system-config-printer-0.7.74.6-2.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update system-config-printer'
Comment 7 Fedora Update System 2007-11-21 22:34:39 EST
system-config-printer-0.7.74.6-2.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update system-config-printer'
Comment 8 Stefan Jensen 2007-11-22 05:59:47 EST
(In reply to comment #6)
>  If you want to test the update, you can install it with 
>  su -c 'yum --enablerepo=updates-testing update system-config-printer'

Ok, works for me perfect now. THANKS!

One thing perhaps: Only when printing a test page, the printer icon doesn't
show up. Maybe it should? Anyway.

Best regards

Stefan
--
Comment 9 Tim Waugh 2007-11-22 06:11:07 EST
It's sort of intentional; well, it's expected anyway.  Test pages are submitted
as user 'guest' instead of as the current user.  This follows the behaviour of
the CUPS web interface.

Thanks for testing.
Comment 10 Fedora Update System 2007-11-26 13:40:06 EST
system-config-printer-0.7.74.7-1.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update system-config-printer'
Comment 11 Fedora Update System 2007-11-26 13:58:18 EST
system-config-printer-0.7.74.7-1.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update system-config-printer'
Comment 12 Fedora Update System 2007-12-20 14:55:38 EST
system-config-printer-0.7.74.8-1.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update system-config-printer'
Comment 13 Fedora Update System 2008-01-15 18:06:22 EST
system-config-printer-0.7.74.8-1.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update system-config-printer'
Comment 14 Fedora Update System 2008-01-22 10:33:50 EST
system-config-printer-0.7.74.9-1.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update system-config-printer'
Comment 15 Fedora Update System 2008-01-22 10:46:37 EST
system-config-printer-0.7.74.9-2.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update system-config-printer'
Comment 16 Fedora Update System 2008-01-27 02:12:25 EST
system-config-printer-0.7.74.10-1.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update system-config-printer'.  You can provide feedback for this update here: http://admin.fedoraproject.org/F8/FEDORA-2007-3416
Comment 17 Fedora Update System 2008-01-29 00:15:49 EST
system-config-printer-0.7.74.10-2.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 18 Fedora Update System 2008-01-29 00:17:43 EST
system-config-printer-0.7.74.10-2.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.