Bug 390511 - double battery detection with 2.6.24
double battery detection with 2.6.24
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: hal (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: David Zeuthen
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F9Blocker
  Show dependency treegraph
 
Reported: 2007-11-19 10:19 EST by Jeremy Katz
Modified: 2013-03-05 22:53 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-04 13:10:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeremy Katz 2007-11-19 10:19:25 EST
With 2.6.24 kernels, laptop batteries get detected twice -- once as the ACPI
battery device (/org/freedesktop/Hal/devices/acpi_BAT0) and once as a computer
power supply (/org/freedesktop/Hal/devices/computer_power_supply_0).  The latter
seems to be due to the bits under the new /sys/class/power_supply
Comment 1 David Zeuthen 2007-11-19 11:06:29 EST
This is an interesting bug; is rawhide tracking 2.6.24 just yet? What hardware?
I'll probably do a hal 0.5.10.1 release soon; would be good to have a fix for
this before f7 and f8 is rebased (hence why I'm cc'ing davej)...
Comment 2 Jeremy Katz 2007-11-19 11:24:48 EST
Yep, rawhide got to 2.6.24-rc Friday-ish.  Just rebooted this morning for the
first time since updating the kernel.  And this is on my HP laptop.  Have a live
image underway and will be able to see if it happens generically across laptops
later today
Comment 3 Charles R. Anderson 2008-02-07 19:13:06 EST
Same double-battery issue happens on IBM ThinkPad T42p and also a Lenovo
ThinkPad T61, both running latest rawhide / F9Alpha release.
Comment 4 Matthias Clasen 2008-02-21 16:01:15 EST
With 2.6.25, I'm seeing triple batteries ! 
Comment 5 Matthias Clasen 2008-03-04 13:10:08 EST
Should be fixed in tomorrows rawhide

Note You need to log in before you can comment on or make changes to this bug.