Bug 39078 - ICP Vortex Controller not recognized at installation
ICP Vortex Controller not recognized at installation
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.1
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-05-04 04:56 EDT by Wolfgang Schleicher
Modified: 2007-04-18 12:33 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-06 08:12:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg.txt to bug 39078 (14.90 KB, text/plain)
2001-05-08 05:58 EDT, Wolfgang Schleicher
no flags Details
lscpi -v to bug 39078 (3.38 KB, text/plain)
2001-05-09 01:26 EDT, Wolfgang Schleicher
no flags Details

  None (edit)
Description Wolfgang Schleicher 2001-05-04 04:56:26 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.01; Windows NT)

Hello,

when installing RedHat 7.1e or trying to update from (working) 6.1e EE 
systems, everytime the 7.1 installation routine does not recognize the 
GDT6538RS SCSI raid controller and crashes when trying to connect to the 
hard disks. Only the two onboard adaptec scsi controller are found.

The affected System is a HP Netser LXPro with 4 PP, 1024 MB RAM and the 
mentioned GDT6538RS raid controller.

2.2.12-45SAPsmp -> /proc/scsi/gdth/2
Disk Array Controller Information:
 Number:        0               Name:           GDT6538RS
 Driver Ver.:   1.14            Firmware Ver.:  2.26.02-R036
 Serial No.:    0x36C112F4      Cache RAM size: 65536 KB

Unfortunately, whatever install methode ist choosen, itB4s actually no 
longer possible to select hardware manually. From my point of view, I do 
not understand why RedHat goes the same way microsoft has gone with w2k, 
when administrators are not allowed to "interfere and interact" during the 
installation proccess (autodetecting plug and pray hardware).

The "workaround" when asked for a driver disk, trying to provide 7.1e with 
the "gdth-driver-disk.img" from 6.2e failed, too.

ICP-Vortex, Germany explained that thatB4s a known bug and that this 
problem has been reported to RedHat.

So when can we expect a working installation routine? I canB4t understand 
why systems running in the past are not longer covered in newer software-
releases.

Thank you for your support!

Regards,
Wolfgang Schleicher
PricewaterhouseCoopers Frankfurt, Germany
Comment 1 Brent Fox 2001-05-04 11:58:52 EDT
The driver disk from 6.2 is not going to work.  That driver was compiled by a
different compiler for a different kernel.

Are you booting off the Red Hat Linux 7.1 cd?
Comment 2 Wolfgang Schleicher 2001-05-07 04:30:05 EDT
Yes,I was booting from a scsi cdrom, and as far as the gdt controller is 
concerned the problem has been solved. But now I have another "little" problem, 
which I hope you can help me with.

So, after upgrading a working rh61e EE to 71e choosing expert mode and using 
the driver disk included in 7.1 the former working network configuration fails.

Again I had no chance to select any additional (nic) adapters during 
installation (only scsi drivers are provided). In 6.1 EE both chipsets, adaptec 
ANA6944 and ICP-Vortex GDT6538RS, were recognized automtically.

Loading the gdth (first) and aic 78xx (second) drivers manually and continue 
the installing from scsi cdrom. After ending the update proccess and rebooting 
the machine, rh7.1 comes up correctly and everything workes fine except the 
network. During the booting phase no error messages (eth0 ...) come up. 

The tulip driver for the digital DS21140 seems to have been loaded correctly 
(that4s what the bootlog says) but no ping outside the localhost works -> 
destination host unreachable!

When checking the logs one error message seems to be interesting (the same 
error-message occured at installation screen when booting from installation 
cdrom). From my point of view, rh71 does not handle the PCI Resources of the 
nic correctly. (see the message log) Maybe, I have to update the bios revision 
(ami bios 1.00.11cdol from 1992)?!

The System is again a HP Netserver LX Pro with 4xPPro, 1024MB RAM, 1xAdaptec 
ANA6944 and ICP-Vortex 6538RS Raid Controller.

"modprobe eth0" shows no error message. 

/var/log/message
...
kernel:	PCI: cannot  allocate resource region 0 of device 00:0f.0
kernel:	PCI: error while updating region 00:0f.0/1
kernel:	eth0: Digital DS21140 Tulip ver 34 at 0xfc80
...

/etc/modules.conf
...
alias eth0 tulip
...

/etc/sysconfig/hwconf
...
class:		network
bus:		pci
detached:	0
device:		eth0
driver:		tulip
desc:		"DEC | DECchip 21140 FastEthernet"
vendorID:	1011
deviceID:	0009
pci type:	1
...

So what has to be done?

Regards,
Wolfgang
Comment 3 Brent Fox 2001-05-07 16:07:29 EDT
This is starting to look like a kernel problem, so I'm changing the component.
Comment 4 Arjan van de Ven 2001-05-07 17:27:03 EDT
Does "ifconfig" should eth0 at all ?
Can you attach the output of "dmesg" to this bug?
Comment 5 Wolfgang Schleicher 2001-05-08 05:58:12 EDT
Created attachment 17666 [details]
dmesg.txt to bug 39078
Comment 6 Wolfgang Schleicher 2001-05-08 06:00:24 EDT
So far, only one of the four ports ist enabled and bound to a static ip-adress.

eth0      Link encap:Ethernet  HWaddr 00:00:D1:1C:7E:E4  
          inet addr:10.56.77.55  Bcast:10.56.77.255  Mask:255.255.255.0
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:12 dropped:0 overruns:0 carrier:12
          collisions:0 txqueuelen:100 
          Interrupt:10 Base address:0xfc80 

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:28 errors:0 dropped:0 overruns:0 frame:0
          TX packets:28 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 

Regards,
Wolfgang

Comment 7 Arjan van de Ven 2001-05-08 06:07:34 EDT
The part below is almost certainly the source of the problem. 
Investigating......

PCI: i440KX/GX host bridge 00:19.0: secondary bus 00
PCI: i440KX/GX host bridge 00:1a.0: secondary bus 02
PCI: Cannot allocate resource region 0 of device 00:0f.0
PCI: Cannot allocate resource region 1 of device 00:0f.0
PCI: Cannot allocate resource region 2 of device 00:0f.0
PCI: Cannot allocate resource region 3 of device 00:0f.0
PCI: Cannot allocate resource region 4 of device 00:0f.0
PCI: Cannot allocate resource region 5 of device 00:0f.0
  got res[40000000:400003ff] for resource 0 of PCI device 8086:0008 (Intel
Corporation)
PCI: Error while updating region 00:0f.0/1 (40000408 != 40000008)
  got res[40000400:400007ff] for resource 1 of PCI device 8086:0008 (Intel
Corporation)
PCI: Error while updating region 00:0f.0/2 (40000808 != 40000008)
  got res[40000800:40000bff] for resource 2 of PCI device 8086:0008 (Intel
Corporation)
PCI: Error while updating region 00:0f.0/3 (40000c08 != 40000008)
  got res[40000c00:40000fff] for resource 3 of PCI device 8086:0008 (Intel
Corporation)
PCI: Error while updating region 00:0f.0/4 (40001008 != 40000008)
  got res[40001000:400013ff] for resource 4 of PCI device 8086:0008 (Intel
Corporation)
PCI: Error while updating region 00:0f.0/5 (40001408 != 40000008)
  got res[40001400:400017ff] for resource 5 of PCI device 8086:0008 (Intel
Corporatio
Comment 8 Arjan van de Ven 2001-05-08 06:11:41 EDT
I hate to be a burden, but the output of "lspci -v" would be useful.
Comment 9 Wolfgang Schleicher 2001-05-09 01:26:20 EDT
Created attachment 17826 [details]
lscpi -v to bug 39078
Comment 10 Arjan van de Ven 2001-05-09 15:29:06 EDT
Can you try using the  de4x5 module instead of the tulip module ?
Comment 11 Wolfgang Schleicher 2001-05-14 05:29:40 EDT
Sorry for taking such a long time to continue the bug discussion. Trying to 
load another module driver (modprobe de4x5) for the nic ends up with the 
message:

...device or resource busy
...de4x5 failed
...insmod de4x5 failed

In the meantime I tried installing a fresh RH62e on this machine but the error 
messages were exactly the same as reported in RH71e. From the beginning of the 
installation process the well known PCI Error messages came up.

I think this must be a problem concerning the kernel.

A newer bios-revision is not avialable at hp, so I would try to put the nic 
into another pci slot on a different bus. 

Maybe, I will have more luck.

Wolfgang
Comment 12 Arjan van de Ven 2001-05-14 05:38:32 EDT
There is a new, experimental, tulip driver available from the maintainer.
In talking to the maintainer, he said he fixed at least 1 bug which could
affect your situation. Would you be willing to test this new driver ?
Comment 13 Wolfgang Schleicher 2001-05-14 07:29:34 EDT
Nevertheless in this case I would prefer installing rather linux 6.1e EE than 
windows nt. 

Of course, any suggestions about this topic would be grateful, so I4m willing 
to do just anything to make this machine run with redhat. 

Thanks,
Wolfgang
Comment 14 Arjan van de Ven 2001-08-02 17:09:24 EDT
There is a new driverdisk that fixes this issue, you can get it from

ftp://ftp.redhat.de/pub/rh-addons/driverdisks/

remember to use "linux dd" on the syslinux prompt.

Note You need to log in before you can comment on or make changes to this bug.