Bug 390791 - ./TestRunner frysk.bindir.TestHpd.testHpdPid panic's system
./TestRunner frysk.bindir.TestHpd.testHpdPid panic's system
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.0
powerpc Linux
low Severity low
: ---
: ---
Assigned To: Steve Best
Red Hat Kernel QE team
:
Depends On:
Blocks: 173278
  Show dependency treegraph
 
Reported: 2007-11-19 13:18 EST by Andrew Cagney
Modified: 2013-04-04 06:30 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-04-04 06:30:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andrew Cagney 2007-11-19 13:18:06 EST
This is preliminary based in information from IBM.
Comment 1 Andrew Cagney 2007-11-21 15:42:08 EST
Carlos reports:

- Works fine when running the first 92 tests (i.e. ./TestRunner -r 10
`head -n 92 testlist`). Adding one more crashes the system.
- - Works fine running the last 95 tests (i.e. ./TestRunner -r 10 `tail
- -n 95 testlist`). Adding one more crashes the system.

Comment 2 Andrew Cagney 2007-11-21 15:47:29 EST
Have you tried trimming from both ends; deleting both the first few and last few
tests.

Also, any chance you can get a screen-shot (even a camera :-) or text of the crash?

Phil's managing to build frysk on ppc now so we might be able to repo.
Comment 3 Carlos Eduardo Seo 2007-11-21 15:58:45 EST
(In reply to comment #2)
> Have you tried trimming from both ends; deleting both the first few and last few
> tests.

No. I'll try that.

> Also, any chance you can get a screen-shot (even a camera :-) or text of the
crash?

No. I'm using a remote machine via ssh and it just reboots.

> Phil's managing to build frysk on ppc now so we might be able to repo.

Great! I hope his hardware is different than mine, so we can rule out any kind
of hardware incompatibilities. I'm building on a dual 970FX.
Comment 5 Phil Muldoon 2007-11-21 17:28:28 EST
I have a F8 PPC4 machine that the test fail on, but do not produce rebooting
issues. I do not have the exact hardware specs for this machine, as it is
remote. The test result, as follows, while undesirable does not cause rebooting.
Perhaps there is another cause for the hardware fail? (ie previous tests run in
the suite?)

-bash-3.2$ ./TestRunner frysk.bindir.TestFhd
Running testHpdPid(frysk.bindir.TestFhd) ...ERROR
  frysk.expunit.TimeoutException: Timeout of 5 expired
Running testHpdCommand(frysk.bindir.TestFhd) ...PASS
Running testHpdCore(frysk.bindir.TestFhd) ...ERROR
  frysk.expunit.TimeoutException: Timeout of 5 expired

Time: 10.282
There were 2 errors:
1) testHpdPid(frysk.bindir.TestFhd)frysk.expunit.TimeoutException: Timeout of 5
expired
   at frysk.expunit.Expect.expectMilliseconds(Expect.java:241)
   at frysk.expunit.Expect.expect(Expect.java:277)
   at frysk.expunit.Expect.expect(Expect.java:297)
   at frysk.expunit.Expect.expect(Expect.java:317)
   at frysk.bindir.TestFhd.testHpdPid(TestFhd.java:75)
   at frysk.junit.Runner.runCases(Runner.java:207)
   at frysk.junit.Runner.runArchCases(Runner.java:241)
   at frysk.junit.Runner.runTestCases(Runner.java:512)
   at TestRunner.main(TestRunner.java:61)
2) testHpdCore(frysk.bindir.TestFhd)frysk.expunit.TimeoutException: Timeout of 5
expired
   at frysk.expunit.Expect.expectMilliseconds(Expect.java:241)
   at frysk.expunit.Expect.expect(Expect.java:277)
   at frysk.expunit.Expect.expect(Expect.java:297)
   at frysk.expunit.Expect.expect(Expect.java:317)
   at frysk.bindir.TestFhd.testHpdCore(TestFhd.java:94)
   at frysk.junit.Runner.runCases(Runner.java:207)
   at frysk.junit.Runner.runArchCases(Runner.java:241)
   at frysk.junit.Runner.runTestCases(Runner.java:512)
   at TestRunner.main(TestRunner.java:61)

FAILURES!!!
Tests run: 3,  Failures: 0,  Errors: 2

Failed after run #0
-bash-3.2$ 
Comment 6 Carlos Eduardo Seo 2007-11-22 11:50:12 EST
Phil

The standalone test runs. The problem happens when the entire testsuite runs, or
when I run the commands in comment #1. Try those, please.

Regards,

Carlos
Comment 7 Andrew Cagney 2007-11-22 16:44:55 EST
Carlos,

Can you try to get the console output from the remote crashing machine?  With
out it I'm not sure how much further progress is possible.
Comment 8 Carlos Eduardo Seo 2007-11-23 09:44:22 EST
Unfortunately, there's no console output. Just a black screen and then, after
some time, the booting procedures. 

Couldn't you reproduce that?

Also, I was discussing with Jose Flavio here and we think this might be caused
by a memory leak in utrace/ptrace, since it takes a lot of tests until the crash
happens. What do you think?

Regards,

Carlos
Comment 10 Steve Best 2013-04-04 06:30:33 EDT
doing some bz cleanup. RHEL 5.10 is very limited release, so closing this as will not fix.

-Steve

Note You need to log in before you can comment on or make changes to this bug.