Bug 390841 - nv_drv fails to choose correct panel size
nv_drv fails to choose correct panel size
Status: CLOSED DUPLICATE of bug 234824
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-nv (Show other bugs)
i386 Linux
high Severity low
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2007-11-19 13:36 EST by Frank Ch. Eigler
Modified: 2008-02-11 17:37 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-02-11 17:37:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
Xorg.0.log (56.71 KB, text/plain)
2007-11-21 06:46 EST, Frank Ch. Eigler
no flags Details
xorg.conf (1.09 KB, text/plain)
2007-11-21 06:48 EST, Frank Ch. Eigler
no flags Details
Xorg.0.log (59.35 KB, text/plain)
2007-11-21 07:00 EST, Frank Ch. Eigler
no flags Details
xorg.conf (923 bytes, application/octet-stream)
2007-11-21 07:01 EST, Frank Ch. Eigler
no flags Details
Xorg.0.log-noconf (57.01 KB, text/plain)
2007-11-21 07:03 EST, Frank Ch. Eigler
no flags Details

  None (edit)
Description Frank Ch. Eigler 2007-11-19 13:36:17 EST
Description of problem:
On a pair of 1600x1200 DFP's on my video card, the nv_drv driver
messes up the panel size, and thence the dual-head/virtual size

(--) PCI:*(1:0:0) nVidia Corporation NV43 [GeForce 6600 GS] rev 162, Mem @
0xfa000000/24, 0xe0000000/28, 0xf9000000/24, BIOS @ 0xfbee0000/17
(II) NV(0): Supported additional Video Mode:
(II) NV(0): clock: 162.0 MHz   Image Size:  432 x 324 mm
(II) NV(0): h_active: 1600  h_sync: 1664  h_sync_end 1856 h_blank_end 2160
h_border: 0
(II) NV(0): v_active: 1200  v_sync: 1201  v_sync_end 1204 v_blanking: 1250
v_border: 0
(II) NV(0): Ranges: V min: 56  V max: 75 Hz, H min: 30  H max: 81 kHz, PixClock
max 170 MHz
(II) NV(0): Monitor name: SyncMaster
(II) NV(0): Serial No: HCHL201539
(II) NV(0): EDID (in hex):
(II) NV(0):     00ffffffffffff004c2dd00131325242
(II) NV(0):     06100103802b20782aee95a3544c9926
(II) NV(0):     0f5054bfef80a94081808140714f0101
(II) NV(0):     010101010101483f403062b0324040c0
(II) NV(0):     1300b0441100001e000000fd00384b1e
(II) NV(0):     5111000a202020202020000000fc0053
(II) NV(0):     796e634d61737465720a2020000000ff
(II) NV(0):     004843484c3230313533390a202000ff
(--) NV(0): CRTC 0 is currently programmed for DFP
(II) NV(0): Using DFP on CRTC 0
(--) NV(0): Panel size is 1280 x 1024
(II) NV(0): EDID vendor "SAM", prod id 464
(II) NV(0): Using EDID range info for horizontal sync
(II) NV(0): Using EDID range info for vertical refresh
(II) NV(0): Printing DDC gathered Modelines:
(II) NV(0): Modeline "1600x1200"x0.0  162.00  1600 1664 1856 2160  1200 1201
1204 1250 +hsync +vsync (75.0 kHz)
(II) NV(0): Not using mode "1600x1200" (no mode of this name)
(--) NV(0): Virtual size is 2560x1024 (pitch 2560)


Please note that the nvidia driver does the right thing.
Sadly, something about fedora 8 plus that driver makes the machine
prone to freezing, thus my attempt to use nv_drv.  However, if it
can't drive the panel at the proper resolution, I'm stuck.
Comment 1 Matěj Cepl 2007-11-21 04:03:00 EST
Thanks for the bug report.  We have reviewed the information you have provided
above, and there is some additional information we require that will be helpful
in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf) and X server log
file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file
attachments using the bugzilla file attachment link below.

Please, make sure, that no remains of nvidia driver are present on your hard
disk when running the test above (and below for that matter), see
http://fedoraproject.org/wiki/Xorg/3rdPartyVideoDrivers for instructions how to
do it.

Could you please also try to run without any /etc/X11/xorg.conf whatsoever and
let X11 autodetect your display and video card? Attach to this bug
/var/log/Xorg.0.log from this attempt as well, please.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 2 Frank Ch. Eigler 2007-11-21 06:46:59 EST
Created attachment 265871 [details]
Comment 3 Frank Ch. Eigler 2007-11-21 06:48:59 EST
Created attachment 265881 [details]

(Same symptoms if the "Monitor" clause is absent or if the "FlatPanel" option
is left at its default "on".)
Comment 4 Frank Ch. Eigler 2007-11-21 07:00:34 EST
Created attachment 265891 [details]

(same, after forcing removal of leftover sneaky nvidia glx module)
Comment 5 Frank Ch. Eigler 2007-11-21 07:01:50 EST
Created attachment 265901 [details]

(same, after removing bug-finding experiments)
Comment 6 Frank Ch. Eigler 2007-11-21 07:03:21 EST
Created attachment 265911 [details]

And this is the Xorg.0.log coming from no xorg.conf.
Comment 7 Adam Jackson 2008-02-11 17:37:59 EST
Yep, it sure does.

*** This bug has been marked as a duplicate of 234824 ***

Note You need to log in before you can comment on or make changes to this bug.