Bug 390871 - Unable to change syntax highlighting in Bluefish
Unable to change syntax highlighting in Bluefish
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: bluefish (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Paul Howarth
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-19 13:55 EST by Adam Deacon
Modified: 2008-02-13 00:11 EST (History)
1 user (show)

See Also:
Fixed In Version: 1.0.7-3.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-13 00:11:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch that was committed upstream to workaround this issue (3.01 KB, patch)
2008-01-19 23:52 EST, Jim Hayward
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 498954 None None None Never

  None (edit)
Description Adam Deacon 2007-11-19 13:55:44 EST
Description of problem:
When you select a file type (e.g. php) from the "Syntax Highlighting" tab in
Preferences, you should be able to change the "PHP Block" start pattern, however
all boxes are empty. They should fill from the settings in
/usr/share/bluefish/highlighting.default.

Version-Release number of selected component (if applicable):

bluefish-1.0.7-2.fc8

How reproducible:
Always

Steps to Reproduce:
1. Edit -> preferences -> Syntax Highlighting
2. Select PHP from filetype
3. Select an entry such as "PHP Block"
  
Actual results:
Details not shown

Expected results:
Details to be shown and editable.

Additional info:
I've tried changing settings directly in file with no affect. Syntax
highlighting is working. If I use <?php...?>, I want to be able to edit it to
use say <?...?>.
Comment 1 Paul Howarth 2007-11-22 07:38:19 EST
Hmm, yes, I can't seem to get the Syntax Highlighting preferences tab to do
anything sane at all.

Have you tried editing ~/.bluefish/highlighting ?
Comment 2 Adam Deacon 2007-11-23 03:45:02 EST
Hi. 

I edited ~/.bluefish/highlighting and the changes took effect but still don't
show anything in the preferences tab. I also tried deleting the file and it was
correctly copied from /usr/share/bluefish/highlighting.default to ~/.bluefish/

The permissions and ownership of the file seem fine.
Comment 3 Daniel Leidert 2008-01-12 13:48:05 EST
This issue has been introduced with Gtk 2.20, however, we did not yet find the
reason (any help is appreciated). More information at GNOME bugzilla.
Comment 4 Jim Hayward 2008-01-19 23:52:15 EST
Created attachment 292284 [details]
Patch that was committed upstream to workaround this issue
Comment 5 Paul Howarth 2008-01-21 10:53:45 EST
Patch works for me (thanks); I've committed it for Fedora 8 and Rawhide, and it
should show in updates-testing after the next push.
Comment 6 Fedora Update System 2008-01-24 17:01:45 EST
bluefish-1.0.7-3.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update bluefish'
Comment 7 Fedora Update System 2008-02-13 00:11:49 EST
bluefish-1.0.7-3.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.