Bug 39088 - koffice unable to do MS imports
koffice unable to do MS imports
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: koffice (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-05-04 08:54 EDT by Dr. Tilmann Bubeck
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-09 01:56:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Dr. Tilmann Bubeck 2001-05-04 08:54:09 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.0; Windows NT; DigExt)

Description of problem:
If you try to import a MS Word file into Kword or a MS Excel file into 
KSpread you get the alert box: "Missing import filter. Could not import 
file of type application/msword".

This is true on a fresh installed RH 7.1 without any modifications. 
Searching results, that these import must be handles by olefilter, which 
is part of the koffice rpm. However, it does not seem to be found... 
Something wrong with the configuration of koffice?

www.koffice.org says, that the MS import filter are not perfect, but they 
work for easy examples. I tried a simple "hello" document without any 
special format.

Same is true for all other koffice components and their corresponding 
filters.

How reproducible:
Always

Steps to Reproduce:
1. Start kword
2. Select "File->Open"
3. Select "MS Word 97" file format
4. Select a MS word file
5. Message above.
	

Actual Results:  Missing import filter. Could not import file of type 
application/msword".

Empty document in Kword.


Expected Results:  Imported file.

Additional info:
Comment 1 Bernhard Rosenkraenzer 2001-05-08 09:21:30 EDT
The M$ import filters are far from complete, largely because the 
specifications of the file format are not (at least not legally) available.

There have been a lot of improvements recently, though. The current version 
(in rawhide) may work better for you.
Comment 2 Dr. Tilmann Bubeck 2001-05-09 01:56:32 EDT
No, maybe I did not make the problem clear. Koffice could not import ANYTHING 
because the import filter is MISSING. 

However, I tried 
ftp://rawhide.redhat.com/pub/redhat/linux/rawhide/i386/RedHat/RPMS/koffice-1.1-
0.beta1.1.i386.rpm
and this RPM includes the missing import filter and it could import (with some 
defencencies) a MS document.

So I still think, this is a BUG in RH 7.1.
Comment 3 Bernhard Rosenkraenzer 2001-05-14 12:32:07 EDT
No, it isn't. It's a bug in the file format actually. They use at least 4 
different MIME types to handle .doc files; By the time KDE 2.0.1 was released, 
we knew only about one.
If the file you used had one of the other mime types, KOffice can't have found 
it.

Note You need to log in before you can comment on or make changes to this bug.