Bug 390971 - vncserver still relies on the xfs server for some fonts
vncserver still relies on the xfs server for some fonts
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: vnc (Show other bugs)
8
i386 Linux
low Severity low
: ---
: ---
Assigned To: Adam Tkac
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-19 14:49 EST by Jim Hennessy
Modified: 2013-04-30 19:37 EDT (History)
2 users (show)

See Also:
Fixed In Version: 4.1.2-24.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-26 13:18:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jim Hennessy 2007-11-19 14:49:12 EST
Description of problem:

I did a fresh install of Fedora 8 and started a VNC server.  When I connect to
that VNC server with a remote viewer I find that I do not have many fonts
available from the "legacy" font set (for example, adobe-courier and
adobe-helvetica) in the VNC session.  By available, I mean they are not
displayed by xfontsel or xlsfonts.  I found that if I install the xorg-x11-xfs
package and start the xfs service, then I have the fonts available again.

Fedora 8 does not install the xfs server by default because of the plan to
eliminate the requirement for one, as documented at
http://fedoraproject.org/wiki/Releases/FeatureNoMoreXFS.  But the vnc-server
package appears to still rely on having xfs running, so perhaps some change to
the vnc server was missed.

Version-Release number of selected component (if applicable):

  vnc-server-4.1.2-23.fc8


How reproducible:  Always


Steps to Reproduce:

1. Install Fedora 8, including vnc-server, but not xorg-x11-xfs.
2. Start the vnc-server and connect to it remotely with a vnc viewer.
3. Run xfontsel or xlsfonts and observe that "standard" fonts like adobe-courier
   and adobe-helvetica are not listed.  In fact, I see only 6 lines of output
   from xlsfonts, so very few are seen by vncserver.
  
Actual results:

I see very few fonts from xlsfonts.

Expected results:

I expect to see quite a few fonts from xlsfonts.

Additional info:
Comment 1 Adam Tkac 2007-12-20 10:18:14 EST
fix is commited in CVS, will be avaliable in next update. Thanks for report
Comment 2 Fedora Update System 2008-03-19 08:29:36 EDT
vnc-4.1.2-24.fc8 has been submitted as an update for Fedora 8
Comment 3 Fedora Update System 2008-03-21 18:19:57 EDT
vnc-4.1.2-24.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update vnc'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F8/FEDORA-2008-2646
Comment 4 Fedora Update System 2008-03-26 13:18:25 EDT
vnc-4.1.2-24.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.