Bug 391001 - Syncing Evolution to a PalmOS device through gnome-pilot often fails
Syncing Evolution to a PalmOS device through gnome-pilot often fails
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: gnome-pilot (Show other bugs)
8
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-19 14:57 EST by Mark Locascio
Modified: 2009-01-09 02:27 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-09 02:27:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Bug report from gpilotd crash (364.93 KB, text/plain)
2007-11-19 14:57 EST, Mark Locascio
no flags Details
Bug report from gpilot crash (10.02 KB, text/plain)
2008-02-01 05:56 EST, gombang102
no flags Details

  None (edit)
Description Mark Locascio 2007-11-19 14:57:18 EST
Description of problem:
Sync is not reliable. Sometimes sync will occur as expected. Sometimes I need to
open gnome-pilot through Evolution menu first (I don't need to do anything, just
open it), then a sync will occur. Sometimes sync chokes on the to-do list.

Version-Release number of selected component (if applicable):
gnome-pilot-2.0.15-10.fc8

How reproducible:
Very reproducible with evolution-2.12.1-3.fc8 and Handspring Visor Prism.

Steps to Reproduce:
1. Open Evolution
2. Hit HotSync button on Visor cradle
3. Sync will fail
4. Click Edit -> Synchronization Options in Evolution menu
5. Close the gnome-pilot window
6. Hit HotSync button again
7. Sync will either proceed to completion or hang while syncing the to-do list
8. Hitting the HotSync button after that usually works.
  
Actual results:
Either the Sync fails to connect, fails to sync the to-do list, or works after
trying the above.

Expected results:
Sync should work reliably.

Additional info:
Once while doing this gpilotd crashed and gave the attached bug report.
Comment 1 Mark Locascio 2007-11-19 14:57:18 EST
Created attachment 263891 [details]
Bug report from gpilotd crash
Comment 2 gombang102 2008-01-15 06:02:19 EST
I can confirm this bug. I am using Evolution 2.12.2 and Palm Tungsten E2, using
libusb. But with me synchronisation usually fails at the very end, when syncing
Saved Preferences. 
Comment 3 Mark Locascio 2008-01-15 21:19:03 EST
I have since updated to evolution-2.12.2-3.fc8. The problem has gotten a little 
worse. Now I get the gpilotd crash reported above on every sync. Then I have to 
click on sync options. Then I try to sync again and the sync hangs and fails on 
the last part (To Do list). After I cancel and try again, sync succeeds.
Comment 4 gombang102 2008-02-01 05:56:06 EST
Created attachment 293710 [details]
Bug report from gpilot crash

It seems the crash only happens after updating the contacts info and
synchronising. When I disabled the EAddress conduit the synchronisation works
without crashes.
Comment 5 Mark Locascio 2008-02-01 14:28:01 EST
This actually seems like two different problems now. I found this link:

https://bugs.launchpad.net/ubuntu/+source/gnome-pilot-conduits/+bug/81170

And I did as it said. I changed the device speed setting to 115200 and now it
doesn't crash/hang on the ToDo's anymore.

I did a couple syncs yesterday, and everything worked perfectly. Tried again
today after adding a couple ToDos on the palm and it wouldn't start the sync. I
had to open the Evolution Synchronization Options before it would sync.
Comment 6 Bug Zapper 2008-11-26 03:34:49 EST
This message is a reminder that Fedora 8 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 8.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '8'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 8's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 8 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 7 Matthew Barnes 2008-11-29 01:16:35 EST
Is this issue still present on Fedora 10 or later?
Comment 8 Mark Locascio 2008-11-29 02:38:27 EST
I will be travelling on business for the next couple weeks. When I return I will have to upgrade to F10 on that computer, and I'll let you know. As it is now, I can sync regularly if I follow a certain procedure...

First, I have to check the system monitor to make sure gpilotd is running. If it's not, in Evolution I start the Synchronization Options applet to get it running.

Then I hit the HotSync button. I haven't figured out what triggers it yet, but the sync usually runs everything fine (Address Book, Calendar, Memos, etc.) until it tries to sync the To Do List. Then it hangs and the sync fails. Then I kill the gpilotd process in System Monitor, start it again through Evolution, and then sync again. Then it usually runs fine.

From there, I can usually sync it just fine until some combination of adding and/or removing To Do List items makes the sync fail again. I haven't figured out what that combination is yet.

That's where it stands as of now. If it's not a problem, let's keep the bug open for a few more weeks until I can get my machine updated to F10 and we'll see where we are.

Thanks!
Comment 9 Matthew Barnes 2008-11-29 09:55:16 EST
Okay, thanks for the update.
Comment 10 Bug Zapper 2009-01-09 02:27:41 EST
Fedora 8 changed to end-of-life (EOL) status on 2009-01-07. Fedora 8 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.