Bug 391011 - Hydrogen doesn't use pulseaudio correctly
Hydrogen doesn't use pulseaudio correctly
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: hydrogen (Show other bugs)
8
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Anthony Green
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-19 15:07 EST by Brian G. Anderson
Modified: 2009-01-09 02:27 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-09 02:27:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Brian G. Anderson 2007-11-19 15:07:48 EST
Description of problem:
When I start hydrogen it takes over the sound system and prevents other
applications sharing sound.  I checked with pavucontrol and sure enough hydrogen
is not registered as using the pulse audio sound server.  I can only get sound
back for other apps by killing hydrogen.

I tried starting hydrogen using padsp (padsp hydrogen), but that didn't help either.

Version-Release number of selected component (if applicable):
hydrogen-0.9.3-9.fc8

How reproducible:
always

Steps to Reproduce:
1. install hydrogen
2. start hydrogen 
3.try and play something through amarok
  
Actual results:
hydrogen drums play but amarok appears to play, but no sound is heard from it. 
Amarok appears in the pulseaudio volume control, but hydrogen doesn't

Expected results:
both apps should appear in the volume control and I should hear both on my speaker.


Additional info:
Comment 1 Lubomir Kundrak 2007-11-19 15:45:24 EST
Thanks for your report, Brian.

This is a known issue - in fact, hydrogen does not contain any pulseaudio
support at all. If I recall correctly, it uses ALSA. That's also why padsp did
not help -- padsp emulates the OSS device.

Please either try to select OSS output in Hydrogen and use padsp, or configure
ALSA to pipe sound output to Pulseaudio.

You might find this paragraph helpful:
http://www.pulseaudio.org/wiki/PerfectSetup#ALSAApplications

Please let me know if you had any success configuring Hydrogen with ALSA or OSS
like this.
Comment 2 Fernando Lopez-Lezcano 2007-11-19 16:00:40 EST
(In reply to comment #1)
> Please either try to select OSS output in Hydrogen and use padsp, or configure
> ALSA to pipe sound output to Pulseaudio.

Or try to use Jack, which is another option in Hydrogen. 
Comment 3 Brian G. Anderson 2007-11-19 16:20:56 EST
Thanks for the help.

A few problems:
1) I can select OSS as a driver, but I get an error about it not being compiled in.
2) I tried creating the ~/.asoundrc file with definitions for the "pulse" device
described in the link you included.  I can use 'aplay -Dpulse Diddley.wav' to
play the diddley song demo exported as a wav file.  However, if I select the
alsa driver and set the device to "pulse", hydrogen will start using 100% of one
of my processors, but not play anything.  The menus are responsive, but the
Diddley demo doesn't play.  I can hit stop and it continues to use 100% of the
CPU.  When I try and set the ALSA hardware device back to "hw:0", hydrogen
freezes--not responding to any input or redraw events--until I kill it.

I haven't tried making a pulse device my default yet.
Comment 4 Lubomir Kundrak 2007-11-20 05:42:22 EST
This sucks. And it needs to be fixed upstream, I am not able to fix it myself now.
Comment 6 Bug Zapper 2008-11-26 03:34:56 EST
This message is a reminder that Fedora 8 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 8.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '8'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 8's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 8 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 7 Bug Zapper 2009-01-09 02:27:47 EST
Fedora 8 changed to end-of-life (EOL) status on 2009-01-07. Fedora 8 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.