Bug 391241 - gnome-sudoku crashes when double clicking 'Very Hard' in new game window
gnome-sudoku crashes when double clicking 'Very Hard' in new game window
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: gnome-games (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Ray Strode [halfline]
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-19 18:34 EST by Tom London
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-20 16:33:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 493886 None None None Never

  None (edit)
Description Tom London 2007-11-19 18:34:39 EST
Description of problem:
gnome-sudoku crashes when double clicking 'very hard' on the 'new game' window:

[tbl@localhost ~]$ gnome-sudoku
Traceback (most recent call last):
  File "/usr/bin/gnome-sudoku", line 36, in <module>
    start_game()
  File "/usr/lib/python2.5/site-packages/gnome_sudoku/gnome_sudoku.py", line
1008, in start_game
    u = UI()
  File "/usr/lib/python2.5/site-packages/gnome_sudoku/gnome_sudoku.py", line
192, in __init__
    if self.select_game():
  File "/usr/lib/python2.5/site-packages/gnome_sudoku/gnome_sudoku.py", line 64,
in _
    ret = fun(ui,*args,**kwargs)
  File "/usr/lib/python2.5/site-packages/gnome_sudoku/gnome_sudoku.py", line
212, in select_game
    self.gsd.change_grid(choice[1],9)
  File "/usr/lib/python2.5/site-packages/gnome_sudoku/gsudoku.py", line 1016, in
change_grid
    self.setup_grid(grid,group_size)        
  File "/usr/lib/python2.5/site-packages/gnome_sudoku/gsudoku.py", line 1048, in
setup_grid
    self.grid = sudoku.InteractiveSudoku(grid,group_size=group_size)
  File "/usr/lib/python2.5/site-packages/gnome_sudoku/sudoku.py", line 614, in
__init__
    SudokuSolver.__init__(self,grid,verbose,group_size)
  File "/usr/lib/python2.5/site-packages/gnome_sudoku/sudoku.py", line 255, in
__init__
    SudokuGrid.__init__(self,grid,verbose=verbose,group_size=group_size)
  File "/usr/lib/python2.5/site-packages/gnome_sudoku/sudoku.py", line 92, in
__init__
    grid.append([int(i) for i in g[start:start+side]])
ValueError: invalid literal for int() with base 10: ''
[tbl@localhost ~]$ 


Version-Release number of selected component (if applicable):
gnome-games-2.21.2-1.fc9

How reproducible:
Every time

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Hans de Goede 2007-11-20 15:47:53 EST
Can you please give better instructions howto reproduce this? Double clicking
very hard is not very clear? Am I supposed to click the buttons so hard the
mouse breaks or .... ?
Comment 2 Ray Strode [halfline] 2007-11-20 16:16:54 EST
In rawhide gnome-games there appears to be a difficulty setting asked before
starting a new game.  

Depending on which one gets picked a file in 

/usr/share/gnome-sudoku/puzzles/

gets loaded.  The very_hard one looks corrupt (just by comparing it to some of
the other ones in vim)
Comment 3 Hans de Goede 2007-11-20 16:24:29 EST
(In reply to comment #2)
> In rawhide gnome-games there appears to be a difficulty setting asked before
> starting a new game.  
> 
> Depending on which one gets picked a file in 
> 
> /usr/share/gnome-sudoku/puzzles/
> 
> gets loaded.  The very_hard one looks corrupt (just by comparing it to some of
> the other ones in vim)

Ah I see...
/me has egg on his face

I'll see if its already filed upstream (one would expect so).
Comment 4 Hans de Goede 2007-11-20 16:29:17 EST
Already known (but not fixed) upstream:
http://bugzilla.gnome.org/show_bug.cgi?id=493886

Since this is a bug in a development version of gnome, I think its best handled
upstream.

Ray, if you agree can you close this with a resolution of upstream please?
Comment 5 Ray Strode [halfline] 2007-11-20 16:33:07 EST
yup.

Note You need to log in before you can comment on or make changes to this bug.