This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 391261 - mrtg rpm should not recreate /etc/cron.d/mrtg
mrtg rpm should not recreate /etc/cron.d/mrtg
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: mrtg (Show other bugs)
4.6
All Linux
low Severity low
: ---
: ---
Assigned To: Vitezslav Crhonek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-19 19:25 EST by rambler8
Modified: 2010-03-18 11:53 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-03-18 11:53:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description rambler8 2007-11-19 19:25:51 EST
The mrtg rpm package should not create or update the /etc/cron.d/mrtg file when 
a package update is performed. 

In my case, i've removed /etc/cron.d/mrtg from my systems because I prefer to 
run mrtg with RunAsDaemon: Yes in the mrtg.cfg file and start mrtg 
via /etc/rc.d/rc.local

Other users may perfer to run mrtg more or less frequently than default the 5 
minute interval or not at all.

In either case, installing an update of the mrtg package requires the 
administrator to manually change or remove the /etc/cron.d/mrtg file to restore 
desired system operation.

To avoid this problem, the /etc/cron.d/mrtg file should only be created when 
the package is initially installed. If it isn't possible to differentiate an 
update from an initial installation, the /etc/cron.d/mrtg file should never be 
created by the mrtg rpm package.
Comment 1 Ondrej Vasik 2010-03-18 11:53:56 EDT
As RHEL-4.9 is last update for RHEL-4 and it is not suitable for new features
and should address only security, performance and critical issues, I'm closing
that bugzilla WONTFIX. If this functionality is still missing in RHEL-5, feel
free to clone that bugzilla against it.

Note You need to log in before you can comment on or make changes to this bug.