Bug 39130 - printing to hp lj 4000 + /bin/pr
Summary: printing to hp lj 4000 + /bin/pr
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: LPRng   
(Show other bugs)
Version: 7.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-05-04 18:46 UTC by Gerald Teschl
Modified: 2007-04-18 16:33 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-01-21 12:44:31 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
LPRng-3.7.4-pr.patch (626 bytes, patch)
2002-01-15 16:45 UTC, Tim Waugh
no flags Details | Diff

Description Gerald Teschl 2001-05-04 18:46:39 UTC
Description of Problem:
I print to a hp laserjet 4000 network printer, set up as a remot unix lpd
printer
using printconf-gui.

I noted that sometimes documents will not print. In such a case
lpq claims that it tries to spool the document 3 times and then
removes it from without any further errors.

In /var/spool/lpd/zra/status I found the following:
2001-05-04-14:58:12.673 soliton zra: Print_job:  could not make '/bin/pr'
process

and since "pr" is in "/usr/bin" I linked /bin/pr to /usr/bin/pr and then it
worked.

Comment 1 Tim Waugh 2002-01-15 16:44:35 UTC
Here is the patch I'm planning to use to fix it.


Comment 2 Tim Waugh 2002-01-15 16:45:01 UTC
Created attachment 42497 [details]
LPRng-3.7.4-pr.patch

Comment 3 Tim Waugh 2002-01-22 13:53:55 UTC
Fixed in LPRng-3.8.4-1.



Note You need to log in before you can comment on or make changes to this bug.