Bug 391341 - mono shipped with f8 doesn't run reflector
mono shipped with f8 doesn't run reflector
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: mono (Show other bugs)
8
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Paul F. Johnson
Fedora Extras Quality Assurance
http://www.aisto.com/roeder/dotnet/
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-19 20:23 EST by Hin-Tak Leung
Modified: 2008-10-11 17:46 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-11 17:46:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
mono -v Reflector.exe >& my-v.log (21.55 KB, application/octet-stream)
2007-11-22 12:27 EST, Hin-Tak Leung
no flags Details

  None (edit)
Description Hin-Tak Leung 2007-11-19 20:23:08 EST
Description of problem:

running  'mono ./Reflector.exe' (after unzipping the download) dies with: 

** (Reflector.exe:1408): WARNING **: exception inside UnhandledException
handler: Object reference not set to an instance of an object

I am filing this bug because with the 1.2.5.1-0.novell rpm's provided 
on http://www.go-mono.com/ for fedora 5, it worked on f7, and
upgrading to f8 brings with it mono-core-1.2.5.1-3.f8 which has the above
problem, and downgrading back to the rpm's provided on go-mono web site
works on f8. 

Version-Release number of selected component (if applicable):

1.2.5.1-3.fc8, also tried 1.2.5.2-2.fc9 (devel).

How reproducible:

Always

Steps to Reproduce:
1. Download reflector.zip from the URL. Just any name/e-mail would do.
2. unzip 
3. run 'mono ./Reflector.exe'
  
Actual results:

** (Reflector.exe:1408): WARNING **: exception inside UnhandledException
handler: Object reference not set to an instance of an object

(the '1408' part differs slightly between different version of reflector)

Expected results:

a GUI appears.

Additional info: 

force-installing the bundle of rpm's in
http://www.go-mono.com/download-stable/fedora-5-x86_64/mono.zip
is a work-around.
Comment 1 Paul F. Johnson 2007-11-20 17:48:54 EST
It's working under rawhide on x86_64 - can you give that version a whirl and see
if it's giving the same problem?
Comment 2 Hin-Tak Leung 2007-11-21 10:34:41 EST
As I reported, I did try the 1.2.5.2-2 rpm's under fc9-devel

ftp://download.fedora.redhat.com/pub/fedora/linux/development/x86_64/os/Packages/

Am I confused that I thought that fedora-devel is rawhide? 
Comment 3 Paul F. Johnson 2007-11-22 08:13:37 EST
It's working fine at this end. Can you attach the full throwback so I can see
where it's going wrong?
Comment 4 Hin-Tak Leung 2007-11-22 12:27:51 EST
Created attachment 267131 [details]
 mono -v Reflector.exe >& my-v.log

mono -v Reflector.exe >& my-v.log ,
then gzip'ed.

Before generating this file, I removed all my novell rpms with 
(the mono team's rpm all have a *.novell release tag):
   rpm -qa |grep 'novell' |xargs rpm -e --nodeps
The reinstalled the as-shipped mono with
   yum install mono-core mono-data mono-winforms

$ rpm -qa |grep 'mono'
mono-core-1.2.5.1-3.fc8.x86_64
mono-web-1.2.5.1-3.fc8.x86_64
mono-winforms-1.2.5.1-3.fc8.x86_64
mono-data-1.2.5.1-3.fc8.x86_64
mono-core-1.2.5.1-3.fc8.i386

I tried mono --debug but there is no additional info; mono --trace
generates a 1.2GB file and still going (and possibly need to be a 
bit more selective). Not sure what 'throwback' means...
Comment 5 Paul F. Johnson 2007-11-23 10:44:55 EST
This has me stumped somewhat - I have it working correctly on x86_64 on my test rig.

How long is the log without zipping it?

Hmmm, it could be that it's looking for something other than those packages as
well. Is it coming up with any sort of report of missing dll files? By the looks
of the app, it will need System.Drawing as well. Install the rest of mono
(including bytefx-ibm-data) and the devel file and we can wittle the problem
down from there.
Comment 6 Hin-Tak Leung 2007-11-23 11:01:06 EST
The attached file was the full -v output. The -trace output was too large (1.2GB
and still going) to attach.

I'll give it a go installing the rest of mono, but I am quite sure that it won't
help - my problem was after an fc7->fc8 upgrade (when fc8 rpm's replaced
novell rpms), so if bytefx-ibm-data was present before the upgrade,
it would have been there after the upgrade (except replaced by an fc8 one) as well.
Comment 7 Hin-Tak Leung 2007-11-23 22:19:38 EST
Didn't find bytefx-ibm-data, but installed bytefx-data-mysql, ibm-data-db2 and
some others; no improvement.
Comment 8 Paul F. Johnson 2008-01-06 17:35:59 EST
Have you installed everything - including the -devel packages for mono and the
likes of gtksharp2? I have the lot installed and it's quite probably something
missing that either reflector looks for and isn't there or something the other
way around...
Comment 9 Hin-Tak Leung 2008-01-06 20:40:01 EST
This is what I have (after doing 
'yum search sharp |<some text processing> | xargs yum install'):

# rpm -qa |grep mono
mod_mono-1.2.1-1.fc7
mono-extras-1.2.5.1-3.fc8
monodoc-1.2.3-1.fc7
mono-web-1.2.5.1-3.fc8
mono-winforms-1.2.5.1-3.fc8
mono-devel-1.2.5.1-3.fc8
mono-debugger-0.31-2.fc7
mono-devel-1.2.5.1-3.fc8
mono-data-oracle-1.2.5.1-3.fc8
mono-data-sqlite-1.2.5.1-3.fc8
mono-core-1.2.5.1-3.fc8
mono-data-sybase-1.2.5.1-3.fc8
mono-nunit-1.2.5.1-3.fc8
mono-core-1.2.5.1-3.fc8
mono-debugger-0.31-2.fc7
mono-data-postgresql-1.2.5.1-3.fc8
mono-data-firebird-1.2.5.1-3.fc8
monodevelop-0.13.1-1.fc7
mono-data-1.2.5.1-3.fc8
mono-locale-extras-1.2.5.1-3.fc8
mono-jscript-1.2.5.1-3.fc8

# rpm -qa |grep sharp
njb-sharp-devel-0.3.0-8.fc7
gtksourceview-sharp-devel-2.0-25.fc7
gtk-sharp2-doc-2.10.0-6.fc8
avahi-ui-sharp-0.6.21-8.fc8
gtk-sharp2-devel-2.10.0-6.fc8
gecko-sharp2-0.12-5.fc8
gtk-sharp2-gapi-2.10.0-6.fc8
gtk-sharp-devel-1.0.10-12.fc7
gtksourceview-sharp-devel-2.0-25.fc7
gtk-sharp2-2.10.0-6.fc8
ice-csharp-devel-3.2.1-12.fc8
gsf-sharp-0.8.1-5.fc8
avahi-sharp-0.6.21-8.fc8
evolution-sharp-devel-0.14.0.1-1.fc8
gtk-sharp-gapi-devel-1.0.10-12.fc7
gtk-sharp-gapi-1.0.10-12.fc7
graphviz-sharp-2.14.1-3.fc8
njb-sharp-devel-0.3.0-8.fc7
gnome-sharp-devel-2.16.0-5.fc8
gtk-sharp-devel-1.0.10-12.fc7
gtk-sharp-1.0.10-12.fc7
dbus-sharp-devel-0.63-8.fc8
gsf-sharp-devel-0.8.1-5.fc8
gtksourceview-sharp-2.0-25.fc7
gnome-sharp-devel-2.16.0-5.fc8
dbus-sharp-0.63-8.fc8
evolution-sharp-devel-0.14.0.1-1.fc8
gtk-sharp2-devel-2.10.0-6.fc8
gecko-sharp2-devel-0.12-5.fc8
ice-csharp-devel-3.2.1-12.fc8
njb-sharp-0.3.0-8.fc7
gecko-sharp2-devel-0.12-5.fc8
evolution-sharp-0.14.0.1-1.fc8
gsf-sharp-devel-0.8.1-5.fc8
ice-csharp-3.2.1-12.fc8
gnome-sharp-2.16.0-5.fc8
gmime-sharp-2.2.10-5.fc8
ipod-sharp-0.6.3-3.fc8
dbus-sharp-devel-0.63-8.fc8
gtk-sharp-gapi-devel-1.0.10-12.fc7

I noticed that I have some *fc7 packages, so I did 
something like 'grep -v '\.fc8' |xargs rpm -e ', and the situation has not
changed (but I did try running it before the removal first). Still:

$ mono Reflector.exe

** (Reflector.exe:1549): WARNING **: exception inside UnhandledException
handler: Object reference not set to an instance of an object

I can give you my 'rpm -qa' , but it might be more useful if you give me yours
and I try doing 'cat your-rpm-list |xargs yum install', if you think 
it is due to a missing package...

Comment 10 Hin-Tak Leung 2008-02-06 16:50:52 EST
Clean new machine, new hard disc, installed fedora 8 x86_64 then yum update;
still won't run; whereas 1.2.6 (they have a totally non-root installer now) from
upstream still does.
Comment 11 Paul F. Johnson 2008-04-21 09:35:00 EDT
It's got me as it's working fine here under rawhide.
Comment 12 Hin-Tak Leung 2008-06-02 22:56:43 EDT
upgraded to fedora 9 (which ships with mono 1.9.1) and it seems to work, alright,
although the graphics sucks. Suggest closing?

Note You need to log in before you can comment on or make changes to this bug.