Bug 391571 - yum-updates makes gamin wake the disk up every 4 seconds due to a bug
yum-updates makes gamin wake the disk up every 4 seconds due to a bug
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: yum-updatesd (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Jeremy Katz
Fedora Extras Quality Assurance
:
Depends On:
Blocks: wakeup 418441
  Show dependency treegraph
 
Reported: 2007-11-20 01:09 EST by Arjan van de Ven
Modified: 2008-01-18 14:51 EST (History)
2 users (show)

See Also:
Fixed In Version: 0.9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-18 14:51:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Arjan van de Ven 2007-11-20 01:09:17 EST
Description of problem:

for some reason, yum-updatesd sets gamin to watch some directories, that turn
out to be actual files not directories. This causes gamin to go wild and wake
the cpu and the disk up every 4 seconds. This isn't very nice for power;
especially the disk part.

From strace:
22:04:13.698538 poll([{fd=3, events=POLLIN}, {fd=4, events=0}, {fd=5,
events=POLLIN}, {fd=4, events=POLLIN}, {fd=7, events=POLLIN}], 5, 4000) = 0
22:04:17.698788 gettimeofday({1195538657, 698846}, NULL) = 0
22:04:17.698920 inotify_add_watch(3, "/var/cache/yum/.gpgkeyschecked.yum",
IN_MODIFY|IN_ATTRIB|IN_MOVED_FROM|IN_MOVED_TO|IN_CREATE|IN_DELETE|IN_DELETE_SELF|IN_MOVE_SELF|IN_UNMOUNT|IN_ONLYDIR)
= -1 ENOTDIR (Not a directory)
22:04:17.699074 inotify_add_watch(3, "/var/cache/yum/timedhosts.txt",
IN_MODIFY|IN_ATTRIB|IN_MOVED_FROM|IN_MOVED_TO|IN_CREATE|IN_DELETE|IN_DELETE_SELF|IN_MOVE_SELF|IN_UNMOUNT|IN_ONLYDIR)
= -1 ENOTDIR (Not a directory)
22:04:17.699213 gettimeofday({1195538657, 699248}, NULL) = 0
22:04:17.699312 poll( <unfinished ...>



notice the ENOTDIR error return because of the IN_ONLYDIR flag..

since yum-updatesd is in the default install it would be really nice if this
could be fixed in an F8 update; right now it takes power for everyone.
Comment 1 Jeremy Katz 2007-11-20 10:31:11 EST
/me mutters something about actively harmful APIs.

Thanks for noticing, fixed in git and I'm prepping an update for sometime within
the next week or so (just want to make sure there aren't other things lurking
before going through the work of pushing it)
Comment 2 Fedora Update System 2007-12-06 15:54:25 EST
yum-updatesd-0.8-2.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update yum-updatesd'
Comment 3 Fedora Update System 2007-12-20 14:52:19 EST
yum-updatesd-0.9-1.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update yum-updatesd'
Comment 4 Fedora Update System 2007-12-28 12:18:59 EST
yum-updatesd-0.9-1.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.