Bug 391701 - kernel crash on boot in firewire module
kernel crash on boot in firewire module
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
8
All Linux
low Severity medium
: ---
: ---
Assigned To: Jarod Wilson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-20 03:58 EST by Alex Kanavin
Modified: 2008-02-21 12:24 EST (History)
8 users (show)

See Also:
Fixed In Version: kernel-2.6.24.2-7.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-21 12:24:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screen shot of the kernel trace (157.81 KB, image/jpeg)
2007-11-20 03:58 EST, Alex Kanavin
no flags Details

  None (edit)
Description Alex Kanavin 2007-11-20 03:58:55 EST
Usually the kernel boots fine (I boot from an external firewire drive), but
today I got a kernel crash on boot. After a poweroff/on everything went fine.
I'm using Fedora 8 with stock 2.6.23.1-42 kernel.

I have attached the screen shot with the trace. Let me know if this is enough or
further info is needed.
Comment 1 Alex Kanavin 2007-11-20 03:58:55 EST
Created attachment 264661 [details]
screen shot of the kernel trace
Comment 2 Kyle McMartin 2008-01-15 20:28:37 EST
Please try the latest stable Fedora 8 kernel, it has numerous firewire fixes.
Comment 3 Andrew Farris 2008-01-15 20:40:03 EST
Stefan Richter pointed out in bug# 428554 that this error looks very much like
my screenshot https://bugzilla.redhat.com/attachment.cgi?id=291491 in comment #3
of that bug.

The latest F8 stable is 2.6.23.9-85, which also has issues with my firewire drive.

It would be interesting to know if you have issues with that one as well Alex,
or if this error ever repeated itself for you at all.
Comment 4 Alex Kanavin 2008-01-15 23:03:11 EST
I think I have only seen this problem once - the "orb reply timed out" was a
much more frequent problem for me. I have since switched to the rawhide kernels
(currently using 2.6.24-0.83.rc5.fc9), and the crash hasn't shown up yet with
them, and the orb timeouts seem to be fixed as well. I can downgrade to latest
f8 2.6.23 kernel, if you want, and see if the problem re-occurs, but it seems
like a quite rare one for me at least.
Comment 5 Jarod Wilson 2008-01-15 23:43:20 EST
(In reply to comment #3)
> The latest F8 stable is 2.6.23.9-85, which also has issues with my firewire drive.

The F8 kernel to try out would be 2.6.23.13-106.fc8 or later, which is where a
significant amount of the firewire updates/fixes went in. I don't believe
anything that new is in updates or updates-testing yet though, so you have to
pull from koji at the moment. The latest build as of this writing can be found here:

http://koji.fedoraproject.org/packages/kernel/2.6.23.14/107.fc8/
Comment 6 Jarod Wilson 2008-01-18 15:15:28 EST
Nb: see the tail end of bug 238606, I think we'll have the orb reply timeout
thing fixed shortly. :)
Comment 7 Christopher Brown 2008-02-13 18:18:06 EST
Hey Jarod,

Re-assigning to you as per triage page.
Comment 8 Jarod Wilson 2008-02-21 12:24:38 EST
Should be resolved in the latest updates-testing kernel (and the latest updates
kernel, iirc). Please reopen if its still a problem.

Note You need to log in before you can comment on or make changes to this bug.