Bug 39174 - xscreensaver crashes when screen locked
xscreensaver crashes when screen locked
Status: CLOSED DUPLICATE of bug 36670
Product: Red Hat Linux
Classification: Retired
Component: xscreensaver (Show other bugs)
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Bill Nottingham
Depends On:
  Show dependency treegraph
Reported: 2001-05-04 20:29 EDT by Tim Pepper
Modified: 2014-03-16 22:20 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2001-05-04 20:31:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
XFree86 crash log (19.01 KB, text/plain)
2001-05-04 20:31 EDT, Tim Pepper
no flags Details

  None (edit)
Description Tim Pepper 2001-05-04 20:29:51 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.4.4-2 i686; en-US; 0.8.1)

Description of problem:
When I lock the screen xscreensaver is crashing.  It happens regardless of
which particular screensaver is set to run.  Once crashed, the screen is
still locked but any attemts to enter the user password at the unlock
prompt fail to authenticate.  I can usually log into another virtual
terminal and kill processes of xscreensaver and whichever screensaver was
running.  The screensaver process is in state TN at this point and
xsreensaver is usually still running.  At this point I can return to X but
it is usually in an unpredictable unstable state and often will very
quickly crash out back to the CLI (I'm in init level 3).  xscreensaver
seems to recognise that the child has died and will sometimes start to
rapidly cycle through all the screensavers, each of which quickly dies and
it loops doing this.

How reproducible:

Steps to Reproduce:
1. Click the lock icon in the panel or click the gnome foot and then "Lock

Actual Results:  Error messages print to the screen in the background and
the xscreensaver login prompt appears but it cannot successfully validate a
valid password.

Expected Results:  The screen should lock and I should be able to
sucessfully log back in.

Additional info:

I've had trouble getting the error output as after a few moments
xscreensaver seems to recognise that its child has failed and it cycles,
obliterating the message.  But it seems like it is:

X error in xmatrix:
X Error failed request:  BadDrawable (invalid Pixmap or Window parameter)
  Major op code of failed request: 62 (X_CopyArea)
  Resource id number of failed request: 0xe00001
  Serial number of failed request: 2980
  Current serial number of output streem: 7249

I'm not sure if it matters but this is the stock XFree86 install on top of
the i810 DRI module of a custom built unpatched 2.4.4 kernel.

Also sometimes I do catch an error message stating:
   Gtk-WARNING **: gtk_widget_size_allocate(): attempt to allocate widget
with width 65527 and height 1:
which may or may not be related.

Finally, I will attach a copy of the log generated one of the times that
this caused an outright crash of X.
Comment 1 Tim Pepper 2001-05-04 20:31:00 EDT
Created attachment 17410 [details]
XFree86 crash log
Comment 2 Bill Nottingham 2001-05-07 09:46:17 EDT

*** This bug has been marked as a duplicate of 36670 ***

Note You need to log in before you can comment on or make changes to this bug.