Bug 391821 - vsftpd file listing issue with wildcard
vsftpd file listing issue with wildcard
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: vsftpd (Show other bugs)
3.9
All Linux
high Severity high
: ---
: ---
Assigned To: Martin Nagy
:
Depends On:
Blocks: 392181
  Show dependency treegraph
 
Reported: 2007-11-20 05:11 EST by Michal Nowak
Modified: 2016-07-26 19:46 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-27 08:16:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Nowak 2007-11-20 05:11:24 EST
+++ This bug was initially created as a clone of Bug #244864 +++

Description of problem:

The wildcarding code misses trivially valid cases

  ls *1

will match

  A1
  b9087654321

but will fail against

  a11

Version-Release number of selected component (if applicable):

vsftpd-2.0.1-5.EL4.5

How reproducible:

always

Steps to Reproduce:
1. create files on server  A1 A21 A11
2. ftp in and ls *1
3.
  
Actual results:

ftp> ls *1
 227 Entering Passive Mode (10,1,2,3,61,93)
 150 Here comes the directory listing.
 -rw-rw-r-- 1 500   500   0 Jun 11 00:30 A1
 -rw-r--r-- 1 0   0   0 Jun 12 01:55 A21

Expected results:

ftp> ls
 227 Entering Passive Mode (10,1,2,3,227,184)
 150 Here comes the directory listing.
 -rw-rw-r-- 1 500   500   0 Jun 11 00:30 A1
 -rw-rw-r-- 1 500   500   0 Jun 11 00:35 A11
 -rw-r--r-- 1 0   0   0 Jun 12 01:55 A21


Additional info:

The problem is due to the fact the match code is not greedy enough. Having found
a match it needs to speculatively scan for further matches without a permanent
failure.
Comment 1 Michal Nowak 2007-11-20 05:16:05 EST
[root@nec-em11 regressions]# rpmquery vsftpd
vsftpd-1.2.1-3E.15


covered-by RHTS script:
/CoreOS/vsftpd/regressions/testbug_wildcard_matching
Comment 2 Radek Vokal 2007-11-27 08:16:02 EST
For RHEL3 we're looking only at security and performance issues. Thus closing as
WONTFIX.

Note You need to log in before you can comment on or make changes to this bug.