Bug 391961 - OpenPegasus SRPM fails to build Test RPM.
OpenPegasus SRPM fails to build Test RPM.
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: tog-pegasus (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Vitezslav Crhonek
Fedora Extras Quality Assurance
:
Depends On: 252462
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-20 06:44 EST by Vitezslav Crhonek
Modified: 2007-11-30 17:12 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-23 06:07:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vitezslav Crhonek 2007-11-20 06:44:50 EST
+++ This bug was initially created as a clone of Bug #252462 +++

Description of problem:
rpmbuild -bb --define 'PEGASUS_BUILD_TEST_RPM 1' tog-pegasus.spec fails.

Note: The OpenPegasus test RPM, tog-pegasus-test-2.6.0-4.ia64.rpm, is an 
internal use only package.  It contains a suite of regression tests that can 
be used to verify that the OpenPegasus product built successfully. tog-pegasus-
test-2.6.0-4.ia64.rpm is NOT intended to be packaged as part of the RHEL 
release.

Version-Release number of selected component (if applicable):
tog-pegasus-2.6.0-4.el5.src.rpm

How reproducible:
This failure is consistently reproducible.

Steps to Reproduce:
1. rpmbuild -bb --define 'PEGASUS_BUILD_TEST_RPM 1' tog-pegasus.spec 
2.
3.
  
Actual results:

g++ -W -Wall -Wno-unused -D_GNU_SOURCE -DTHREAD_SAFE -D_REENTRANT -O2 -
fvisibility=hidden -DPEGASUS_ENABLE_SSL_CRL_VERIFICATION -
DPEGASUS_DISABLE_PERFINST -DPEGASUS_ENABLE_CMPI_PROVIDER_MANAGER -
DPEGASUS_USE_RELEASE_CONFIG_OPTIONS -DPEGASUS_USE_RELEASE_DIRS -
DPEGASUS_OVERRIDE_DEFAULT_RELEASE_DIRS -fPIE -pie -Wl,-z,relro,-z,now,-
z,nodlopen,-z,noexecstack -L/usr/src/redhat/BUILD/pegasus/build/lib -
o /usr/src/redhat/BUILD/pegasus/build/bin/TestQualifierList /usr/src/redhat/BUI
LD/pegasus/build/obj/Pegasus/Common/tests/QualifierList/QualifierList.o -
lpegcommon -ldl -lpthread -lcrypt -lpam
touch /usr/src/redhat/BUILD/pegasus/build/bin/TestQualifierList

touch /usr/src/redhat/BUILD/pegasus/build/bin/TestQualifierList

make[1]: Leaving directory 
`/usr/src/redhat/BUILD/pegasus/src/Pegasus/Common/tests/QualifierList'
make -C /usr/src/redhat/BUILD/pegasus/src/Pegasus/Common/tests/Queue
make: *** /usr/src/redhat/BUILD/pegasus/src/Pegasus/Common/tests/Queue: No 
such file or directory.  Stop.
make: *** [/usr/src/redhat/BUILD/pegasus/build/bin/TestQueue] Error 2
error: Bad exit status from /var/tmp/rpm-tmp.56473 (%build)


Expected results:
rpmbuild -bb --define 'PEGASUS_BUILD_TEST_RPM 1' tog-pegasus.spec  completes 
successfully and tog-pegasus-test-2.6.0-4.ia64.rpm is created.


Additional info:

-- Additional comment from denise.eckstein@hp.com on 2007-08-16 01:42 EST --
Created an attachment (id=161432)
Proposed Change


-- Additional comment from pm-rhel@redhat.com on 2007-10-15 23:48 EST --
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.

Note You need to log in before you can comment on or make changes to this bug.