This service will be undergoing non-disruptive maintenance at 07:20 UTC, 2018-12-14. It is expected to last approximately 30 minutes
Bug 392 - slow routed initialization messed up other daemons
Summary: slow routed initialization messed up other daemons
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: routed (Show other bugs)
(Show other bugs)
Version: 5.1
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: David Lawrence
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1998-12-11 22:52 UTC by brownb
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1998-12-12 20:31:51 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description brownb 1998-12-11 22:52:19 UTC
My Red Hat Linux 5.1 machine lives on a large network.  When
it boots, routed takes a while to initialize and get a
stable set of routes.  Whatever script next follows
routed in the initialization sequence fails.  In my case,
/etc/rc.d/init.d/xntpd is the script executed right after
/etc/rc.d/init.d/routed.  It fails because no route exists
to my time server.  If I place a 10 or 20 second delay in
the xntpd script before it executes ntpdate, then everything
works fine.
I should not have to rely on ad hoc delays ... routed script
should be smarter ...

Comment 1 Aleksey Nogin 1998-12-12 18:56:59 UTC
On a large and complex network, you should consider using gated
instead of routed.

Comment 2 Jeff Johnson 1998-12-12 20:31:59 UTC
This problem is caused by your router configuration, not
Red Hat's initscripts, routed, and/or gated. There is
a finite and unpredictable delay in distributing routes
that cannot be solved by "a smarter routed script".

You should look at configuring a local default route to
a nearby router or machine willing to route your packets
if at all possible. If you *must* run a router, you should try
the following
	1) configuring static default route (gated is *much* easier)
	2) changing your router configuration to minimize the
	length of time that it takes to get "plugged in"


Note You need to log in before you can comment on or make changes to this bug.