Bug 3920 - Network won't initialize during Kickstart install.
Network won't initialize during Kickstart install.
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
6.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-07-06 15:02 EDT by marty.trey
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-07-07 09:31:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description marty.trey 1999-07-06 15:02:20 EDT
Using the following kickstart file, after installation of
all packages, during the network configuraion step, the
install cannot do a reverse name lookup to determine the
host and domain name.  Upon further inspection the network
device driver is being installed and eth0 exists, but is not
configured.
--------- begin ks.cfg ----------
lang en
device ethernet 3c59x
network --bootproto static --ip 192.168.73.7 --netmask
255.255.255.0 --gateway 192.168.73.254 --nameserver
192.168.72.140
cdrom
keyboard us

zerombr yes
clearpart --all
#
# part <mntpt> --size <size in megs> [--grow] [--maxsize
<size in megs>]
#
part / --size 250
part swap --size 64
part /usr --size 800 --grow --maxsize 1200
part /var --size 500 --grow --maxsize 800
part /tmp --size 100 --grow --maxsize 800

install
mouse msintellips/2
timezone US/Eastern
xconfig --monitor "Generic08"
skipx yes
auth --useshadow --enablemd5
lilo --location mbr

# '@ component' may be used to include entire components
%packages
@ Printer Support
@ KDE
@ DOS/Windows Connectivity
@ SMB (Samba) Connectivity
@ DNS Name Server
@ Network Management Workstation
@ C Development
@ Development Libraries
@ C++ Development
@ Extra Documentation
--------- end ks.cfg ----------
Comment 1 Jay Turner 1999-07-06 15:51:59 EDT
One thing that might be causing what you are seeing is the fact that
it appears as if the network line of the config file is not on one
single line.  It has to be on the same line in order for the install
to process it.  As it is (where it appears to be on different lines)
the nameserver is not getting set and therefore no name lookup!
Reopen this bug if you still have problems after modifying this.
Comment 2 marty.trey 1999-07-07 06:52:59 EDT
The network directive is on one single line.
Comment 3 Jay Turner 1999-07-07 09:31:59 EDT
Looking back I realize this is a known bug in the installer.  This
issue is being assigned to a developer for further action.

*** This bug has been marked as a duplicate of 192 ***

Note You need to log in before you can comment on or make changes to this bug.