Bug 392091 - listen needs an explicit "Requires: python-tunepimp"
listen needs an explicit "Requires: python-tunepimp"
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: listen (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Haïkel Guémar
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-20 07:49 EST by Alex Lancaster
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version: 0.5-16.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-21 22:35:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alex Lancaster 2007-11-20 07:49:56 EST
Description of problem:
listen needs an explicit dependency on python-tunepimp otherwise musicbrainz
support will be absent.  

Version-Release number of selected component (if applicable):
listen-0.5-15.fc7.1

How reproducible:
Always

Steps to Reproduce:
1. yum install
2. run listen
  
Actual results:
$ sudo yum install listen
Setting up Install Process
Parsing package install arguments
Resolving Dependencies
--> Running transaction check
---> Package listen.i386 0:0.5-15.fc7.1 set to be updated
--> Processing Dependency: python-musicbrainz2 for package: listen
--> Processing Dependency: /usr/bin/puid for package: listen
--> Processing Dependency: python-sqlite2 for package: listen
--> Running transaction check
---> Package python-sqlite2.i386 1:2.3.3-1.fc7 set to be updated
---> Package python-musicbrainz2.noarch 0:0.4.1-1.fc7 set to be updated
---> Package libtunepimp.i386 0:0.5.3-9.fc8 set to be updated
--> Processing Dependency: libofa.so.0 for package: libtunepimp
--> Running transaction check
---> Package libofa.i386 0:0.9.3-10.fc8 set to be updated
--> Finished Dependency Resolution

Dependencies Resolved

=============================================================================
 Package                 Arch       Version          Repository        Size 
=============================================================================
Installing:
 listen                  i386       0.5-15.fc7.1     fedora            701 k
Installing for dependencies:
 libofa                  i386       0.9.3-10.fc8     fedora             64 k
 libtunepimp             i386       0.5.3-9.fc8      fedora            370 k
 python-musicbrainz2     noarch     0.4.1-1.fc7      fedora            128 k
 python-sqlite2          i386       1:2.3.3-1.fc7    fedora             90 k

At run-time (step 2) you get this:

$ listen 
No musicbrainz support (tunepimp missing or version < 0.5)

Expected results:

Musicbrainz support to work out of the box

Additional info:

Installing python-tunepimp manually fixes this (the warning goes away).  Hence
the spec file needs an additional "Requires: python-tunepimp".  Because it is
not a compiled soname dependency but a Python module, the auto dep generator
doesn't know to add it.
Comment 1 Haïkel Guémar 2007-11-20 13:16:18 EST
Fixed on all supported releases (FC-6 -> Rawhide)
Since it's a packaging issue, it willgo straight to updates.
Thanks. :o)
Comment 2 Alex Lancaster 2007-11-20 19:45:58 EST
Can you please include bug #392091 in the list of bugs in the update.  The
update will then automatically close this bug as ERRATA.  Then it is clear in
the updates e-mail which bug the update fixes.  Re-opening so this is closed by
the updates system automatically.
Comment 3 Fedora Update System 2007-11-21 22:35:35 EST
listen-0.5-16.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.