Bug 3921 - pump causes SLOW networking
pump causes SLOW networking
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: pump (Show other bugs)
6.0
i386 Linux
high Severity high
: ---
: ---
Assigned To: David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-07-06 16:15 EDT by kgb
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-07-07 14:07:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description kgb 1999-07-06 16:15:03 EDT
Hi,

I am experiencing problems with DHCP networking after
upgrading
to RH 6.0 - the speed to local machines appears very slow
and
intermittent. e.g. doing an 'ftp' and a 'ls' seems to hang
on long directory listings. Looks like some kind of timeout
problem.

Turning off dhcp and hardwiring addresses completely cures
the problem so it
seems pump is too blame.

I tried installing all the networking related errata but
this did
not cure the problem.

Anyway I thought I would report this, though I would not be
surprised
if this is not the first...

Dr Karl Glazebrook



attach my current rpm list :-
setup-2.0.2-1
filesystem-1.3.4-4
basesystem-6.0-4
ldconfig-1.9.5-15
AfterStep-1.7.90-3
AfterStep-APPS-990329-2
aktion-0.3.3-1
AnotherLevel-0.9-1
glibc-2.1.1-6
chkconfig-1.0.6-1
mktemp-1.5-1
termcap-9.12.6-15
libtermcap-2.0.8-13
bash-1.14.7-16
ncurses-4.2-18
info-3.12f-4
fileutils-4.0-1
mailcap-2.0.1-1
grep-2.3-2
textutils-1.22-9
apache-1.3.6-7
pump-0.6.7-1
ash-0.2-17
at-3.1.7-8
audiofile-0.1.6-5
audiofile-devel-0.1.6-5
aumix-1.18.2-2
authconfig-1.8-1
autoconf-2.13-5
automake-1.4-4
awesfx-0.4.3a-2
bc-1.05a-4
bdflush-1.5-10
bin86-0.4-7
bind-utils-8.2-6
binutils-2.9.1.0.23-1
bison-1.27-3
byacc-1.9-11
cdecl-2.5-9
cdp-0.33-12
chkfontpath-1.4.1-1
sed-3.02-4
console-tools-19990302-13
control-center-1.0.5-20
control-center-devel-1.0.5-20
control-panel-3.11-2
e2fsprogs-1.14-4
rmt-0.4b4-7
cpio-2.4.2-12
cpp-1.1.2-12
cproto-4.6-2
cracklib-2.7-5
cracklib-dicts-2.7-5
crontabs-1.7-6
ctags-3.2-1
cvs-1.10.5-2
desktop-backgrounds-1.0.0-6
shadow-utils-980403-12
dev-2.7.7-1
dialog-0.6-14
diffutils-2.7-16
dip-3.3.7o-14
dosemu-0.99.10-4
ed-0.2-12
ee-0.3.8-7
egcs-1.1.2-12
egcs-c++-1.1.2-12
egcs-objc-1.1.2-12
eject-2.0.2-3
ElectricFence-2.1-1
elm-2.5.0-0.2pre8
enlightenment-0.15.5-32
enlightenment-conf-0.15-5
esound-0.2.12-4
esound-devel-0.2.12-4
etcskel-2.0-1
exmh-2.0.2-7
expect-5.28-29
faces-devel-1.6.1-16
faq-6.0-1
fetchmail-5.0.0-1
file-3.26-6
findutils-4.1-31
finger-0.10-24
flex-2.5.4a-6
fnlib-0.4-8
fnlib-devel-0.4-8
freetype-1.2-6
ftp-0.10-22
fvwm-1.24r-17
fvwm2-2.2-5
fvwm2-icons-2.2-5
fwhois-1.00-11
gawk-3.0.3-7
gd-1.3-5
gd-devel-1.3-5
gdb-4.17.0.11-6
gdbm-1.7.3-19
gdbm-devel-1.7.3-19
gdm-1.0.0-35
gedit-0.5.1-3
gettext-0.10.35-8
getty_ps-2.0.7j-7
gftp-1.13-4
ghostscript-5.10-7
ghostscript-fonts-5.10-3
gimp-1.0.4-3
gimp-libgimp-1.0.4-3
git-4.3.17-5
glib-1.2.1-2
glib-devel-1.2.1-2
glib10-1.0.6-5
kernel-2.2.5-22
glibc-devel-2.1.1-6
gmc-4.5.30-12
gmp-2.0.2-8
gnome-audio-1.0.0-6
gnome-audio-extra-1.0.0-6
gnome-core-1.0.4-34
gnome-core-devel-1.0.4-34
gnome-games-1.0.2-10
gnome-games-devel-1.0.2-10
gnome-libs-1.0.8-8
gnome-libs-devel-1.0.8-8
gnome-linuxconf-0.22-1
gnome-media-1.0.1-3
gnome-objc-1.0.2-4
gnome-objc-devel-1.0.2-4
gnome-pim-1.0.7-2
gnome-pim-devel-1.0.7-2
gnome-users-guide-1.0.5-4rh
gnome-utils-1.0.1-6
gnorpm-0.8-5
gnotepad+-1.1.3-2
gnumeric-0.23-2
gpm-1.17.5-3
gpm-devel-1.17.5-3
gqview-0.6.0-3
groff-1.11a-9
gtk+-1.2.1-10
gtk+-devel-1.2.1-10
gtk+10-1.0.6-5
gtk-engines-0.5-16
gtop-1.0.1-3
guile-1.3-6
gv-3.5.8-7
gzip-1.2.4-14
hdparm-3.3-5
helptool-2.4-7
howto-6.0-4
ical-2.2-9
ImageMagick-4.2.2-4
imlib-1.9.5-4
imlib-cfgeditor-1.9.5-4
imlib-devel-1.9.5-4
indexhtml-6.0-1
initscripts-4.16-1
isapnptools-1.18-2
ispell-3.1.20-15
kbdconfig-1.9.2-1
kdeadmin-1.1.1pre2-1
kdebase-1.1.1pre2-2
kdegames-1.1.1pre2-2
kdegraphics-1.1.1pre2-1
kdelibs-1.1.1pre2-2
kdemultimedia-1.1.1pre2-1
kdenetwork-1.1.1pre2-1
kdesupport-1.1.1pre2-1
kdeutils-1.1.1pre2-1
kernel-2.2.5-15
net-tools-1.52-2
kernel-pcmcia-cs-2.2.5-22
kernelcfg-0.5-5
knfsd-1.2.2-4
korganizer-1.1.1pre2-1
kpilot-3.1b8_pgb-1
kpppload-1.04-4
ld.so-1.9.5-11
less-332-6
lha-1.00-11
libc-5.3.12-31
libghttp-1.0.2-3
libghttp-devel-1.0.2-3
libgr-2.0.13-17
libgr-devel-2.0.13-17
libgr-progs-2.0.13-17
libgtop-1.0.1-3
libgtop-devel-1.0.1-3
libjpeg-6b-9
libjpeg-devel-6b-9
libpng-1.0.3-2
libpng-devel-1.0.3-2
libstdc++-2.9.0-12
libtermcap-devel-2.0.8-13
libtiff-3.4-6
libtiff-devel-3.4-6
libungif-4.1.0-2
libungif-devel-4.1.0-2
libxml-1.0.0-2
libxml-devel-1.0.0-2
lilo-0.21-6
pwdb-0.58-3
pam-0.66-18
sh-utils-1.16-23
redhat-release-6.0-1
linuxconf-1.14r4-4
linuxconf-devel-1.14r4-4
logrotate-3.2-1
losetup-2.9o-1
lpg-0.4-4
lpr-0.35-1
lrzsz-0.12.20-2
lynx-2.8.1-11
m4-1.4-12
mailx-8.1.1-8
make-3.77-6
MAKEDEV-2.5-1
man-1.5g-2
man-pages-1.23-3
mc-4.5.30-12
metamail-2.7-20
mikmod-3.1.5-5
mingetty-0.9.4-10
minicom-1.82-5
mkbootdisk-1.2-2
mkdosfs-ygg-0.3b-11
mkinitrd-2.0-1
mkxauth-1.7-11
modemtool-1.21-6
modutils-2.1.121-12
mount-2.9o-1
mouseconfig-3.9-1
mpage-2.4-7
mpg123-0.59q-6
mt-st-0.5b-3
mtools-3.9.1-5
multimedia-2.1-15
mutt-0.95.4us-4
ncftp-3.0beta18-3
ncompress-4.2.4-14
ncurses-devel-4.2-18
utempter-0.5-2
netcfg-2.20-2
netkit-base-0.10-29
netscape-communicator-4.6-1
apmd-3.0beta5-8
newt-0.40-9
newt-devel-0.40-9
nmh-0.27-8
ntsysv-1.0.6-1
ORBit-0.4.3-2
ORBit-devel-0.4.3-2
passwd-0.58-1
patch-2.5-8
perl-5.00503-2
pilot-link-0.9.0-8
pilot-link-devel-0.9.0-8
pine-4.10-2
playmidi-2.4-7
playmidi-X11-2.4-7
pmake-2.1.33-5
portmap-4.0-15
ppp-2.3.7-2
printtool-3.40-3
procmail-3.13.1-2
procps-2.0.2-2
psmisc-18-2
python-1.5.1-10
pythonlib-1.22-5
qt-1.44-6
quota-1.66-6
rcs-5.7-10
rdate-0.960923-8
rdist-6.1.5-7
readline-2.2.1-5
readline-devel-2.2.1-5
redhat-logos-1.0.5-1
rhs-hwdiag-0.36-1
rhs-printfilters-1.51-2
rhsound-1.8-1
rootfiles-5.2-5
routed-0.10-14
rpm-3.0-6.0
rpm-devel-3.0-6.0
rsh-0.10-25
rusers-0.10-23
rwho-0.10-23
rxvt-2.6.PRE2-5
sag-0.6-3
samba-2.0.3-8
sash-2.1-4
sendmail-8.9.3-10
setconsole-1.0-8
setserial-2.15-2
setuptool-1.2-2
sharutils-4.2-12
slang-1.2.2-4
slang-devel-1.2.2-4
slocate-1.4-7
slrn-0.9.5.4-5
sndconfig-0.33-1
sox-12.15-5
stat-1.5-11
statserial-1.1-13
strace-3.1-17
svgalib-1.3.1-5
svgalib-devel-1.3.1-5
switchdesk-1.7.0-1
switchdesk-gnome-1.7.0-1
switchdesk-kde-1.7.0-1
sysklogd-1.3.31-6
SysVinit-2.74-11
talk-0.11-1
tar-1.12-9
tcl-8.0.4-29
tclx-8.0.4-29
tcp_wrappers-7.6-7
tcsh-6.08.00-5
telnet-0.10-27
tetex-0.9-17
tetex-afm-0.9-17
tetex-dvilj-0.9-17
tetex-dvips-0.9-17
tetex-latex-0.9-17
tetex-xdvi-0.9-17
texinfo-3.12f-4
tftp-0.10-23
time-1.7-9
timeconfig-2.7-1
timed-0.10-23
timetool-2.5-5
tin-1.4_990216-3
tix-4.1.0.6-29
tk-8.0.4-29
tkinter-1.5.1-10
tksysv-1.0-6
tmpwatch-1.7-1
traceroute-1.4a5-14
trn-3.6-16
umb-scheme-3.2-9
unzip-5.31-5
urw-fonts-1.1-8
usermode-1.9-1
usernet-1.0.9-2
util-linux-2.9o-13
uucp-1.06.1-19
vim-common-5.3-7
vim-minimal-5.3-7
vixie-cron-3.0.1-33
which-1.0-11
wmconfig-0.9.5-1
words-2-12
x11amp-0.9_alpha3-6
X11R6-contrib-3.3.2-6
xanim-27070-4
Xaw3d-1.3-21
Xaw3d-devel-1.3-21
xbanner-1.31-7
xchat-0.9.4-3
Xconfigurator-4.2.3-1
xdosemu-0.99.10-4
xfm-1.3.2-13
XFree86-3.3.3.1-49
XFree86-75dpi-fonts-3.3.3.1-49
XFree86-devel-3.3.3.1-49
XFree86-libs-3.3.3.1-49
XFree86-xfs-3.3.3.1-49
xinitrc-2.3-1
xmailbox-2.5-7
xmorph-1996.07.12-7
xpaint-2.4.9-8
xpm-3.4j-5
xpm-devel-3.4j-5
xrn-9.01-3
xxgdb-1.12-10
yp-tools-2.2-1
ypbind-3.3-20
zip-2.1-8
zlib-1.1.3-5
zlib-devel-1.1.3-5
XFree86-SVGA-3.3.3.1-49
egcs-g77-1.1.2-12
pgplot-5.2.0-7rh60
PDL-2.002-1rh60
perl-pgplot-2.11-4rh60
mswordview-0.5.14-1
netscape-common-4.6-1
wu-ftpd-2.5.0-2
xscreensaver-3.09-4
kernel-source-2.2.5-22
kernel-headers-2.2.5-22
Comment 1 David Lawrence 1999-07-07 14:07:59 EDT
We have not been able to reproduce this in our test lab. Also we use
pump and dhcp on most of our internal workstations and have not seen
any slowdown caused by it.
Comment 2 Michael McConachie 1999-07-20 14:36:59 EDT
I had the same problem with the dialup to my ISP.  The fix (in my
case, anyway) was to use the new version of pump and to alias the
compression modules in /etc/conf.modules.

alias ppp-compress-21 bsd_comp
alias ppp-compress-26 ppp_deflate
alias ppp-compress-24 ppp_deflate

I went from an average of 5 min logins to my isp not being happy. ;)

Note You need to log in before you can comment on or make changes to this bug.