Bug 39210 - linuxconf over xiinetd does not work
Summary: linuxconf over xiinetd does not work
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: linuxconf
Version: 7.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Nalin Dahyabhai
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-05-05 14:23 UTC by Harald Hoyer
Modified: 2007-04-18 16:33 UTC (History)
2 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2006-02-21 18:47:58 UTC


Attachments (Terms of Use)

Description Harald Hoyer 2001-05-05 14:23:47 UTC
Description of Problem:
linuxconf web interface does not work

How Reproducible:
always

Steps to Reproduce:
1. ntsysv , activate linuxconf
2. linuxconf, activate web access
3. http://localhost:98

Actual Results:
endless select, accept loop

Expected Results:
linuxconf web gui

Additional Information:

Comment 1 Alan O 2001-05-11 15:14:36 UTC
Same thing happens for me. If I telnet in to localhost port 98 xinetd opens the
connection, but offering the HTTP command "GET / HTTP/1.0" doesn't do anything
(same happens with Netscape and Lynx). Further, when I kill the telnet session
with ^], linuxconf still runs in the background, and according to top, uses all
the cpu (98%).

Comment 2 Harald Hoyer 2001-05-11 15:23:58 UTC
BTW, start linuxconf with
$ linuxconf --http
then it will listen to port 3000, http://localhost:3000 


Comment 3 Alan O 2001-05-11 15:40:49 UTC
Ok, that doesn't even come close to working. linuxconf --http does not listen on
any port. Running "netstat -l --numeric-ports" even shows that nothing is
listening on port 3000. Of course, you can't telnet or point a browser to it
either. From my experience with xinetd services (some could be different), they
operate on stdin and stdout. Running "linuxconf --http" (which, by the way is
what xinetd runs. see /etc/xinetd.d/linuxconf-web) sets it up to receive http
commands (thru stdin) and send back html (thru stdout). Neither of these involve
listening on any port.

Comment 4 Harald Hoyer 2001-05-14 08:23:25 UTC
You have to enable the http mode in the linuxconf GUI first!


Comment 5 flemmon 2001-05-18 02:05:22 UTC
I am seeing the same looping behavior on RHL 7.1, too. Bugzilla issue #40303 
seems relevant, and was helpful to getting the proper configuration established 
and port assignment done. However, it still doesn't solve the looping problem 
on my system, although the submitter indicates it did the trick on getting a 
usable linuxconf working on his setup.

Comment 6 Nikolai Turchanikov 2001-07-19 04:16:18 UTC
recently posted on red hat updates ftp site
xinetd v. 2.3.0 solves the problem of initial
browser connection, but when it comes to the Accept change,
the browser indicates broken connection (lynx message:
"Unexpected network error; connection aborted").
At the same time, xinitd syslog entry pops the message:
"warning: can't get client address: Transport endpoint is not
connected"


Comment 7 Brent Fox 2002-06-05 16:22:10 UTC
Closing because we don't ship linuxconf anymore

Comment 8 Red Hat Bugzilla 2006-02-21 18:47:58 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.