Bug 392211 - Make the extension directory version-independent
Make the extension directory version-independent
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Aillon
Fedora Extras Quality Assurance
FF3RawhideClose
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-20 08:27 EST by Alexander Kahl
Modified: 2008-07-01 16:03 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-01 13:01:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Mozilla Foundation 311008 None None None Never

  None (edit)
Description Alexander Kahl 2007-11-20 08:27:49 EST
Currently, Firefox' directory for system-wide installed extensions resides in
%{_libdir}/firefox-%{version}/
thus packages containing such extensions either have to use triggerscripts or
require a specific version of Firefox so they have to be updated each time a
Firefox version bump occurs in order to use the new location. 
This state creates extraneous work for all maintainers of Firefox extension
packages such as beagle and mugshot, additionally in case of triggerscripts
non-owned directories are being created and can be left behind, e.g.
rpm -qf
/usr/lib64/firefox-2.0.0.9/extensions/\{fda00e13-8c62-4f63-9d19-d168115b11ca\}
file
/usr/lib64/firefox-2.0.0.9/extensions/{fda00e13-8c62-4f63-9d19-d168115b11ca} is
not owned by any package

(the directory was created by beagle to install its extension)

Firefox plugins on the other hand are already handled in a version-independent
way by residing in 
%{_libdir}/mozilla/plugins

Please patch Firefox to also have its extension location in a
version-independent place, I suggest
%{_libdir}/mozilla/extensions
Comment 1 Matěj Cepl 2007-12-20 11:47:48 EST
We just updated the Firefox version in Fedora/development from 2.0 to a 3.0
pre-release version, which improves performance, memory usage, and fixes many
bugs and crashes.

Closing as CANTFIX since we aren't fixing bugs filed against 2.0 now that 3.0 is
in.  If this bug is still present in rawhide using a Firefox 3.0 version, please
re-open this bug.

Thanks and Happy Holidays
Comment 2 Alexander Kahl 2007-12-27 17:34:55 EST
This problem does persist in Firefox 3 / Rawhide - at least neither the rpm nor
the source package's files (spec file etc.) list any version-independent
extension directory so I guess there is none.
Comment 3 Christopher Aillon 2007-12-31 13:29:17 EST
Need to look into fixing upstream 311008
Comment 4 Christopher Aillon 2008-01-05 21:22:56 EST
Taking this.
Comment 5 Bug Zapper 2008-05-13 23:56:48 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 6 Christopher Aillon 2008-07-01 13:01:56 EDT
I fixed this upstream and it's in F9 and rawhide. 
https://bugzilla.mozilla.org/show_bug.cgi?id=311008
Comment 7 Alexander Kahl 2008-07-01 15:51:14 EDT
Great! Which revision or version will include the fix?
Comment 8 Christopher Aillon 2008-07-01 15:55:44 EDT
It's been fixed for about 6 months....
Comment 9 Alexander Kahl 2008-07-01 16:03:54 EDT
OK great; I will test it and report back as soon as I can.

Note You need to log in before you can comment on or make changes to this bug.