Bug 392281 - Miro does not play videos
Summary: Miro does not play videos
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: Miro
Version: 8
Hardware: x86_64
OS: Linux
low
high
Target Milestone: ---
Assignee: Thorsten Scherf
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-11-20 13:40 UTC by Victor Bogado
Modified: 2008-06-19 17:00 UTC (History)
6 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2008-06-19 17:00:21 UTC


Attachments (Terms of Use)

Description Victor Bogado 2007-11-20 13:40:12 UTC
Description of problem:
Miro does not play any movies, it downloads them and the downloaded files can be
played with the default totem installation, but when I try to watch them inside
Miro it only shows a gray screen for one or two seconds while the progress runs
at a higher then normal speed. No sound or video appear to show. 

Version-Release number of selected component (if applicable):
Miro-1.0-1.fc8.x86_64 from updates-testing, but the current 0.9.x from the non
testing were also showing the same problems.

How reproducible:
every time I want to watch a movie.


Additional info:
I do have the gstreamer-bad and ugly drivers installed. I am also happy to test
anything you may need.

Comment 1 Edmond Hui 2007-11-21 00:27:29 UTC
I am encounter the same issue. Again, gstreamer-bad/ugly are installed.

Comment 2 Lukas Brausch 2007-11-26 12:56:32 UTC
I could solve this issue by doing the following: 

1.) Install the packages "gstreamer-bad", "gstreamer-ugly" and "gstreamer-ffmpeg"
2.) You need to edit the file VideoDisplay.py to change the frontend from Xine
to gstreamer. The file is (at my system) located at
/usr/lib64/python2.5/site-packages/miro/frontend_implementation. There you have
to make sure the following lines fit these: 
            # using both renderers at once still sometimes causes problems
            #self.add_renderer("xinerenderer")
            self.add_renderer("gstrenderer")
3.) Save the file as root and enjoy Miro! :-) 

Comment 3 Victor Bogado 2007-11-27 19:11:42 UTC
This work arround has worked for me. 

Comment 4 Alex Lancaster 2007-11-28 00:13:35 UTC
(In reply to comment #2)
> I could solve this issue by doing the following: 
> 
> 1.) Install the packages "gstreamer-bad", "gstreamer-ugly" and "gstreamer-ffmpeg"
> 2.) You need to edit the file VideoDisplay.py to change the frontend from Xine
> to gstreamer. The file is (at my system) located at
> /usr/lib64/python2.5/site-packages/miro/frontend_implementation. There you have
> to make sure the following lines fit these: 
>             # using both renderers at once still sometimes causes problems
>             #self.add_renderer("xinerenderer")
>             self.add_renderer("gstrenderer")
> 3.) Save the file as root and enjoy Miro! :-) 

Interesting.  What happens if you don't edit the VideoDisplay.py file (I revert
the change) and install xine-lib-extras-nonfree from livna or freshrpms?  Does
it work then?  We probably need to decide which backend to ship by default and
provide a way for the user to switch (this last is probably an upstream issue).

Comment 5 Lukas Brausch 2007-11-29 21:43:14 UTC
> What happens if you don't edit the VideoDisplay.py file (I revert
> the change) and install xine-lib-extras-nonfree from livna or freshrpms?
It doesn't work and a lot of strange things happen. For example the videos look
like being on LSD and one can see colours everywhere. Furthermore the videos
surge very strong. 

> We probably need to decide which backend to ship by default
I personally recommend to use gstreamer because of the issues mentioned above. 

Comment 6 Paul Jenner 2008-01-28 20:45:29 UTC
Same thing happens for me on F7 with standard xine-lib backend - videos download
fine (YouTube Flash content only tested so far) but then playing fails with no
video, no sound and progress bar much quicker than expected.

Comment 7 Paul Jenner 2008-01-28 20:57:54 UTC
Same as comment #2 and comment #3 - changing to gstreamer backend worked great
for me.

Out of interest, code indicates this can be set with a gconf key:

values = gconf.client_get_default().get("/apps/miro/renderers")
        if values == None:
            # using both renderers at once still sometimes causes problems
            #self.add_renderer("xinerenderer")
            self.add_renderer("gstrenderer")

Comment 8 Victor Bogado 2008-03-11 16:17:09 UTC
I am reviewing, and closing any bug that I have reported that is not an issue
anymore as to aid people with the bugz backlog mentioned by Jon Stanley on the
fedora planet. But this bug is still relevant and affecting me. 

Comment 9 Paul Jenner 2008-03-18 18:43:22 UTC
Still the same for me on F7 with latest updates:

[psj@localhost ~]$ rpm -q Miro xine-lib
Miro-1.1.2-1.fc7
xine-lib-1.1.10.1-1.fc7.1

Comment 10 Paul Jenner 2008-04-05 19:20:11 UTC
Still the same for me on F7 with latest updates:

[psj@localhost ~]$ rpm -q Miro xine-lib
Miro-1.2-1.fc7
xine-lib-1.1.10.1-1.fc7.1

The workaround to use Gstreamer rather than xine renderer is now easier since
this has been made a user option in Miro 1.2. From Video | Options, choose
Playback and select gstreamer as the renderer to play videos from the drop down.
Then restart Miro.

Comment 11 Alex Lancaster 2008-04-05 23:12:34 UTC
Comment #10 indicates that the issue is with xine-lib, not with Miro itself, as
it works OK with gstreamer, so changing products.  

We also have bug #439631 for Miro which is about making gstreamer being the
default video backend which might be the best workaround for most users.  (Need
to check if gstreamer can play most videos that xine-lib can).

Comment 12 Rex Dieter 2008-04-07 18:03:38 UTC
This is still all on Miro, I see no evidence (yet) xine-lib is at fault here.

More power to making gstreamer switch or as an option.

Comment 13 Paul Jenner 2008-04-10 19:06:20 UTC
Agreed this is a Miro issue.

In my case it is caused by me missing xine-lib codecs. If I attempt to play the
downloaded YouTube Flash content in xine, it gives me a user friendly error
dialogue saying that I don't have the codec. If I try to play it in Miro, there
is no error but the playing fails. Miro should handle this better.

Re: comment #12 - gstreamer is an option choosable by the user. Just the default
renderer in the Fedora package is xine and not gstreamer.

Comment 14 Rex Dieter 2008-04-15 14:56:10 UTC
I take back comment #12, xine-lib-1.1.11.1-1 was broken for some codecs,
xine-lib-1.1.11.1-2 is fixed.

Comment 15 will kahn-greene 2008-06-19 16:41:36 UTC
As of Miro 1.2.3, you can switch between the xine and GStreamer renderers in the
Miro preferences panel.  Going forward, GStreamer will become the default
renderer.  We also made some adjustments allowing you to pick the xine driver
and GStreamer imagesink you want.  Hopefully this will alleviate a set of issues
people are having with interesting video cards.

Comment 16 Alex Lancaster 2008-06-19 17:00:21 UTC
As Will said in comment #15, this is now an option in Miro-1.2.3 and later
(which is in Fedora >=7) and all remaining issues appear to be fixed, so closing
bug.


Note You need to log in before you can comment on or make changes to this bug.