Bug 39231 - The MAXFAIL patch for ppp-watch from bug #10639 is broken (fix available)
Summary: The MAXFAIL patch for ppp-watch from bug #10639 is broken (fix available)
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: initscripts (Show other bugs)
(Show other bugs)
Version: 7.1
Hardware: All Linux
medium
high
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-05-05 20:39 UTC by Alex Kanavin
Modified: 2014-03-17 02:20 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-12 22:35:27 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
A fix for MAXFAIL (491 bytes, patch)
2001-05-05 20:40 UTC, Alex Kanavin
no flags Details | Diff

Description Alex Kanavin 2001-05-05 20:39:30 UTC
The patch to make ppp-watch honor MAXFAIL option is broken. It calls
ifup-ppp the second time immidiately after it has already been called.
Therefore:

a) forced redial makes ppp-watch exit prematurely
b) busy line makes ppp-watch give up after just two attempts
c) ppp-watch exits after first disconnect and ifdown does not work
afterwards - pppd has to be killed by hand

All this because the second ifup-ppp reports a "can't lock port" error to
ppp-watch making it exit with an error.

I've created a very simple patch to fix this and I'd really appreciate if
it was integrated into rawhide (or even better, pushed as an errata, if you
consider it severe enough).

Comment 1 Alex Kanavin 2001-05-05 20:40:40 UTC
Created attachment 17469 [details]
A fix for MAXFAIL

Comment 2 arjen 2001-05-12 18:24:33 UTC
The current implementation doesn't seem to allow for infinite retries.
To fix this one could allow for negative MAXFAIL values which should
be interpreted as: REALLY PERSIST, keep on trying.

The test after incrementing dialCount should be changed from:
if ( dialCount < maxfail ) {
to:
if ( maxfail < 0 || dialCount < maxfail ) {

Comment 3 Alex Kanavin 2001-05-12 22:35:23 UTC
Infinite retries are actually possible without your proposed change: simply set
the MAXFAIL to 0 (zero) or omit it alltogether from your ifcfg file. That's
because in the sources all this maxfail stuff is prefixed by 

if ( maxfail != 0 ) {

Comment 4 Bill Nottingham 2001-05-17 20:05:11 UTC
Thanks, the fix will be in initscripts-5.88-1.

Comment 5 R.K.Aa. 2001-06-19 06:53:37 UTC
Any hint as to when initscripts-5.88-1 will be available?

Comment 6 bug 2001-07-03 05:40:07 UTC
Where is this errata? PERSIST=yes doesn't work as it should (I assume because 
of this bug) on a number of my servers and it's giving me major headaches.


Note You need to log in before you can comment on or make changes to this bug.